<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="de-DE" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, maximum-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://entwickler.de/xmlrpc.php" />
    
    <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/entwickler.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423481258370-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423481258370-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_contentAD_Startpage_Wordpress', [300, 250], 'div-gpt-ad-1423481258370-2').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_FullsizeAD1_Wordpress', [468, 60], 'div-gpt-ad-1423481258370-3').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_leaderboard2_Wordpress', [728, 90], 'div-gpt-ad-1423481258370-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423481258370-5').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423481258370-6').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423481258370-7').addService(googletag.pubads());
		// HOCKEYSTICK
		googletag.defineSlot('/21339274/entwickler.de-hockeystick-right', [160, 600], 'div-gpt-ad-1472121133864-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de-hockeystick-top', [728, 90], 'div-gpt-ad-1472121133864-1').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();
		});
		</script>
		
    <title>Microservices-Trends 2017: Strategien, Tools &amp; Frameworks</title>
<link rel="shortcut icon" type="image/x-icon" href="https://entwickler.de/wp-content/themes/entwicklerDE/public/img/favicon.ico" />
<!-- This site is optimized with the Yoast SEO plugin v4.5 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Microservices gehören zu den wichtigsten neuen Architektur-Konzepten. Doch weshalb sind Entwickler von Microservices überzeugt?"/>
<meta name="news_keywords" content="agile, cloud, container, continuous delivery, devops, domain-driven design, microservices, umfrage" />
<link rel="original-source" href="https://entwickler.de/online/development/microservices-trends-2017-579796021.html" />
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://jaxenter.de/microservices-trends-55937" />
<link rel="publisher" href="https://plus.google.com/u/0/b/106823074878206058879/106823074878206058879/posts"/>
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Microservices-Trends 2017: Strategien, Tools &amp; Frameworks" />
<meta property="og:description" content="Microservices gehören zu den wichtigsten neuen Architektur-Konzepten. Doch weshalb sind Entwickler von Microservices überzeugt?" />
<meta property="og:url" content="https://jaxenter.de/microservices-trends-55937" />
<meta property="og:site_name" content="entwickler.de" />
<meta property="article:publisher" content="https://www.facebook.com/entwickler.de" />
<meta property="article:tag" content="agile" />
<meta property="article:tag" content="cloud" />
<meta property="article:tag" content="container" />
<meta property="article:tag" content="continuous delivery" />
<meta property="article:tag" content="DevOps" />
<meta property="article:tag" content="domain-driven design" />
<meta property="article:tag" content="microservices" />
<meta property="article:tag" content="umfrage" />
<meta property="article:section" content="Development" />
<meta property="article:published_time" content="2017-04-12T13:51:10+02:00" />
<meta property="article:modified_time" content="2017-04-12T16:10:53+02:00" />
<meta property="og:updated_time" content="2017-04-12T16:10:53+02:00" />
<meta property="og:image" content="https://entwickler.de/wp-content/uploads/2017/04/Untitled.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="450" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Microservices gehören zu den wichtigsten neuen Architektur-Konzepten. Doch weshalb sind Entwickler von Microservices überzeugt?" />
<meta name="twitter:title" content="Microservices-Trends 2017: Strategien, Tools &amp; Frameworks" />
<meta name="twitter:site" content="@entwickler" />
<meta name="twitter:image" content="https://entwickler.de/wp-content/uploads/2017/04/Untitled.jpg" />
<meta name="twitter:creator" content="@entwickler" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maps.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="entwickler.de &raquo; Feed" href="https://entwickler.de/feed" />
<link rel="alternate" type="application/rss+xml" title="entwickler.de &raquo; Kommentar-Feed" href="https://entwickler.de/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="entwickler.de &raquo; Microservices-Trends 2017: Strategien, Tools &#038; Frameworks Kommentar-Feed" href="https://entwickler.de/online/development/microservices-trends-2017-579796021.html/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/entwickler.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://entwickler.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='db_twitter_feed-default-css'  href='https://entwickler.de/wp-content/plugins/devbuddy-twitter-feed/assets/feed.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://entwickler.de/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://entwickler.de/wp-includes/css/dashicons.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='gmw-style-css'  href='https://entwickler.de/wp-content/plugins/geo-my-wp/assets/css/style.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='gmw-cl-style-dep-css'  href='https://entwickler.de/wp-content/plugins/geo-my-wp/assets/css/gmw-cl-style-dep.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sands-jobbookmark-plugin-css'  href='https://entwickler.de/wp-content/plugins/sands-jobbookmark-plugin/include/style.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sands-top-article-slider-css'  href='https://entwickler.de/wp-content/plugins/sands-top-article-slider/assets/top-article-slider.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sands_jobspot-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/assets/stylesheets/jobspot.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sands_jobs_jobalert_styles_bs_min-css'  href='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/css/bootstrap.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sands_jobs_jobalert_styles_bs_theme-css'  href='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/css/bootstrap-theme.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='//entwickler.de/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='//entwickler.de/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?x93936' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='//entwickler.de/wp-content/plugins/woocommerce/assets/css/woocommerce.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://entwickler.de/wp-content/plugins/wp-polls/polls-css.css?x93936' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://entwickler.de/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpfront-scroll-top-css'  href='https://entwickler.de/wp-content/plugins/wpfront-scroll-top/css/wpfront-scroll-top.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://entwickler.de/wp-includes/js/mediaelement/mediaelementplayer.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://entwickler.de/wp-includes/js/mediaelement/wp-mediaelement.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-style-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/style.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-fontawesome-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/fonticons/font-awesome.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-chosen-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/chosen/chosen.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-responsive-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/responsive.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-scrollpane-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/jquery.jscrollpane.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-magnific-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/magnific-popup.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-carousel-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/owl-carousel/owl.carousel.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-woocommerce-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/woocommerce.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-style-midnightblue-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/style-midnightblue.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-additional-style-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/jkreativ-icon/jkreativ-icon.min.css?x93936' type='text/css' media='all' />
<style id='jeg-additional-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jeg_font-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,700,400italic,700italic%7CLora:400,400italic' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-fontawesome-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/fontawesome/font-awesome.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-framework-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/framework/bootstrap.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-layouts-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/layouts/layouts.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-grid-responsive-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/responsive.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-lightbox-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/lightbox/lightbox.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-mixitup-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/mixitup/mixed.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='bsf-Defaults-css'  href='https://entwickler.de/wp-content/uploads/smile_fonts/Defaults/Defaults.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-twitterbootstrap-css'  href='https://entwickler.de/wp-content/plugins/woocommerce-twitterbootstrap/css/woocommerce-twitterboostrap.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-css'  href='https://entwickler.de/wp-content/plugins/sabai/assets/css/main.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-font-awesome-css'  href='https://entwickler.de/wp-content/plugins/sabai/assets/css/font-awesome.min.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-discuss-css'  href='https://entwickler.de/wp-content/plugins/sabai-discuss/assets/css/main.min.css?x93936' type='text/css' media='all' />
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/jquery/jquery.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/jquery/jquery-migrate.min.js?x93936'></script>
<script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?libraries=places&#038;key=AIzaSyA9QVPRKdNm3gpEd2_JmnD4n6U8tW2RFuk&#038;region=DE&#038;language=DE&#038;sansor=false&#038;ver=2.7'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/html5-responsive-faq/js/hrf-script.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxjobsubmissionajax = {"ajaxurl":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands_job_processing_form/js/sandsjobprocessing.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxjobalert = {"ajaxurl":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/js/sandsjobsalert.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/js/bootstrap.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/wpfront-scroll-top/js/wpfront-scroll-top.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/masonry/masonry.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/lightbox/lightbox-2.6.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/mixitup/jquery.mixitup.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/custom.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var afp_vars = {"afp_nonce":"73c168f5ce","afp_ajax_url":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/ajax-filter-posts.js?x93936'></script>
<link rel='https://api.w.org/' href='https://entwickler.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://entwickler.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://entwickler.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.3" />
<meta name="generator" content="WooCommerce 2.6.14" />
<link rel='shortlink' href='https://entwickler.de/?p=579796021' />
<link rel="alternate" type="application/json+oembed" href="https://entwickler.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fentwickler.de%2Fonline%2Fdevelopment%2Fmicroservices-trends-2017-579796021.html" />
<link rel="alternate" type="text/xml+oembed" href="https://entwickler.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fentwickler.de%2Fonline%2Fdevelopment%2Fmicroservices-trends-2017-579796021.html&#038;format=xml" />
	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<script type="text/javascript" src="https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/functions.js?x93936"> </script> <script type="text/javascript" src="https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/jquery-validate.bootstrap-tooltip.min.js?x93936"> </script> <script type="text/javascript" src="https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/jquery.validate.min.js?x93936"> </script> <link rel="stylesheet" type="text/css" media="all" href="https://entwickler.de/wp-content/themes/entwicklerDE/assets/stylesheets/sands-style.css?x93936" /><link rel="stylesheet" type="text/css" media="all" href="https://entwickler.de/wp-content/themes/entwicklerDE/assets/stylesheets/kiosk-style.css?x93936" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://entwickler.de/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?x93936" media="screen"><![endif]--><link rel="amphtml" href="https://entwickler.de/online/development/microservices-trends-2017-579796021.html/amp" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><!-- WooCommerce Colors -->
<style type="text/css">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</style>
<!--/WooCommerce Colors-->
    <script type="text/javascript">var templateDirUrl = 'https://entwickler.de/wp-content/themes/entwicklerDE';</script> 
    


<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
<script type="text/javascript">
    window.cookieconsent_options = {"message":"Diese Website verwendet Cookies von Google, um ihre Dienste bereitzustellen, Anzeigen zu personalisieren und Zugriffe zu analysieren. Informationen darüber, wie du die Website verwendest, werden an Google weitergegeben.","dismiss":"Einverstanden","learnMore":"Mehr Infos","link":"https://entwickler.de/datenschutz","theme":"dark-bottom"};
</script>

<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js?x93936"></script>
<!-- End Cookie Consent plugin -->
</head>
<body Development class="post-template-default single single-post postid-579796021 single-format-standard jmagz post-microservices-trends-2017 category-development wpb-js-composer js-comp-ver-5.0.1 vc_responsive">
             
       
	           
<nav id="mobile-menu" role="navigation">
    <section class="mobile-menu-container">
        <section class="mobile-search">
            <form method="get" class="search-form" action="https://entwickler.de/">
    <input type="text" autocomplete="off" name="s" placeholder="Suchbegriff eingeben und Enter drücken">
    <button type="submit" name="button"><i data-loading="fa fa-spinner fa-spin" data-normal="fa fa-search" class="fa fa-search"></i></button>
</form>        </section>
				<div class="sand-mobile-cat-block">
		<h3>Themen</h3>		
			<div id="nav_menu-15" class="widget widget_nav_menu"><div class="menu-entwickler-online-cat-sub-navi-container"><ul id="menu-entwickler-online-cat-sub-navi" class="menu"><li id="menu-item-255830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255830"><a href="https://entwickler.de/online/php">PHP</a></li>
<li id="menu-item-255831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255831"><a href="https://entwickler.de/online/windowsdeveloper">Windows Developer</a></li>
<li id="menu-item-255832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255832"><a href="https://entwickler.de/online/mobile">Mobile</a></li>
<li id="menu-item-255833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255833"><a href="https://entwickler.de/online/javascript">JavaScript</a></li>
<li id="menu-item-255839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255839"><a href="https://entwickler.de/online/iot">IoT</a></li>
<li id="menu-item-255834" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-255834"><a href="https://entwickler.de/online/development">Development</a></li>
<li id="menu-item-255843" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255843"><a href="https://entwickler.de/online/agile">Agile</a></li>
<li id="menu-item-261621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261621"><a href="https://entwickler.de/online/tools">Tools</a></li>
<li id="menu-item-255842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255842"><a href="https://entwickler.de/online/ux">UX</a></li>
<li id="menu-item-255836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255836"><a href="https://entwickler.de/online/web">Web</a></li>
<li id="menu-item-255835" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255835"><a href="https://entwickler.de/online/webmagazin">WebMagazin</a></li>
<li id="menu-item-270629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-270629"><a href="https://entwickler.de/tag/.net">.NET</a></li>
<li id="menu-item-274742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-274742"><a href="https://entwickler.de/tv">entwickler.tv</a></li>
</ul></div></div>		</div>
		<div class="clear"></div>
				
        <ul id="menu-mobile-menu" class=""><li id="menu-item-579778783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-579778783 bgnav"><a href="https://tutorials.entwickler.de?utm_source=entwickler.de&amp;utm_medium=referral&amp;utm_campaign=hauptnavi">.tutorials</a></li><li id="menu-item-149197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149197 bgnav"><a href="/kiosk">.kiosk</a></li><li id="menu-item-245524" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245524 bgnav"><a href="/jobs">.jobs</a></li><li id="menu-item-149201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149201 bgnav"><a href="https://entwickler.de/magazine">.magazine</a></li><li id="menu-item-149203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149203 bgnav"><a href="/shop">.shop</a></li><li id="menu-item-149199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149199 bgnav"><a href="/events">.events</a></li><li id="menu-item-149204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149204 bgnav"><a href="/press">.press</a></li><li id="menu-item-149206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149206 bgnav"><a href="https://entwickler.de/kontakt">.service</a></li><li id="menu-item-206104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206104 bgnav"><a href="https://entwickler.de/fragen-antworten">.q&#038;a</a></li><li id="menu-item-149207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149207 bgnav"><a href="https://entwickler.de/my-account">Anmelden|Abmelden</a></li><li id="menu-item-149208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149208 bgnav"><a href="https://entwickler.de/kiosk">Registrieren</a></li></ul>    </section>
</nav><header class="header-style-1">
   
    <div id="navbar">
                <a href="https://entwickler.de" class="logo"><img src="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" data-at2x="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" alt=&#039;Das ganze Spektrum der Softwareentwicklung&#039;></a>
        <a href="https://entwickler.de" class="mobile-logo"><img src="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" data-at2x="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" alt=&#039;Das ganze Spektrum der Softwareentwicklung&#039;></a>
        <nav class="main-nav">
            <ul class="menu">
    <li class="home "><a href="https://entwickler.de"><i class="fa fa-home"></i></a></li>
    <li id="menu-item-149149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-149149 bgnav"><a href="/online">.online</a>
<ul class="childmenu">
	<li id="menu-item-239437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239437 bgnav"><a href="https://entwickler.de/online/php">PHP</a></li>
	<li id="menu-item-239436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239436 bgnav"><a href="https://entwickler.de/online/windowsdeveloper">Windows Developer</a></li>
	<li id="menu-item-239440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239440 bgnav"><a href="https://entwickler.de/online/mobile">Mobile</a></li>
	<li id="menu-item-239439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239439 bgnav"><a href="https://entwickler.de/online/javascript">JavaScript</a></li>
	<li id="menu-item-239444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239444 bgnav"><a href="https://entwickler.de/online/iot">IoT</a></li>
	<li id="menu-item-239441" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-239441 bgnav"><a href="https://entwickler.de/online/development">Development</a></li>
	<li id="menu-item-239445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239445 bgnav"><a href="https://entwickler.de/online/netzkultur">Netzkultur</a></li>
	<li id="menu-item-239447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239447 bgnav"><a href="https://entwickler.de/online/agile">Agile</a></li>
	<li id="menu-item-261651" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261651 bgnav"><a href="https://entwickler.de/online/tools">Tools</a></li>
	<li id="menu-item-239448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239448 bgnav"><a href="https://entwickler.de/online/ux">UX</a></li>
	<li id="menu-item-239438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239438 bgnav"><a href="https://entwickler.de/online/web">Web</a></li>
	<li id="menu-item-239449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239449 bgnav"><a href="https://entwickler.de/online/e-business">E-Business</a></li>
	<li id="menu-item-239435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239435 bgnav"><a href="https://entwickler.de/online/webmagazin">WebMagazin</a></li>
	<li id="menu-item-239453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239453 bgnav"><a href="https://entwickler.de/online/startups">Startups</a></li>
</ul>
</li>
<li id="menu-item-579778657" class="entwickler-magazine-add-item menu-item menu-item-type-custom menu-item-object-custom menu-item-579778657 bgnav"><a href="https://tutorials.entwickler.de?utm_source=entwickler.de&amp;utm_medium=referral&amp;utm_campaign=hauptnavi">.tutorials</a></li>
<li id="menu-item-149155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149155 bgnav"><a href="/kiosk">.kiosk</a></li>
<li id="menu-item-202600" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-202600 bgnav"><a href="https://entwickler.de/jobs">.jobs</a>
<ul class="childmenu">
	<li id="menu-item-291611" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-291611 bgnav"><a href="https://entwickler.de/jobs">Alle Jobs</a></li>
	<li id="menu-item-202599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-202599 bgnav"><a href="https://entwickler.de/jobs/add-job">Job hinzufügen</a></li>
	<li id="menu-item-202598" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-202598 bgnav"><a href="https://entwickler.de/job-faq">FAQ</a></li>
</ul>
</li>
<li id="menu-item-149164" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-149164 bgnav"><a href="https://entwickler.de/magazine">.magazine</a>
<ul class="childmenu">
	<li id="menu-item-170164" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170164 bgnav"><a href="https://entwickler.de/kontakt">Kontakt &#038; Leserservice</a></li>
	<li id="menu-item-149167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149167 bgnav"><a href="https://entwickler.de/entwickler-magazin">Entwickler Magazin</a></li>
	<li id="menu-item-149168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149168 bgnav"><a href="https://entwickler.de/php-magazin">PHP Magazin</a></li>
	<li id="menu-item-164903" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164903 bgnav"><a href="https://entwickler.de/windows-developer-magazin">Windows Developer</a></li>
	<li id="menu-item-149171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149171 bgnav"><a href="https://entwickler.de/mobile-technology">Mobile Technology</a></li>
	<li id="menu-item-294796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294796 bgnav"><a href="https://entwickler.de/javascript-kompendium">JavaScript Kompendium</a></li>
	<li id="menu-item-164905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164905 bgnav"><a href="https://entwickler.de/sharepoint-magazin">SharePoint Kompendium</a></li>
</ul>
</li>
<li id="menu-item-149172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149172 bgnav"><a href="/shop">.shop</a></li>
<li id="menu-item-149156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149156 bgnav"><a href="/events">.events</a></li>
<li id="menu-item-149176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-149176 bgnav"><a href="/press">.press</a>
<ul class="childmenu">
	<li id="menu-item-149177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149177 bgnav"><a href="https://entwickler.de/press/buecher">Bücher &#038; E-Books</a></li>
	<li id="menu-item-149182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149182 bgnav"><a href="https://entwickler.de/press/shortcuts">Shortcuts</a></li>
	<li id="menu-item-149273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149273 bgnav"><a href="https://entwickler.de/kontakt-service-entwickler-press">Kontakt &#038; Service</a></li>
</ul>
</li>
<li id="menu-item-149186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-149186 bgnav"><a href="https://entwickler.de/kontakt">.service</a>
<ul class="childmenu">
	<li id="menu-item-159169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-159169 bgnav"><a title="Fragen und Antworten" href="https://entwickler.de/fragen-antworten">Q&#038;A</a>
	<ul class="childmenu">
		<li id="menu-item-159171" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-159171 bgnav"><a href="https://entwickler.de/qa/frage-stellen">Eine Frage stellen</a></li>
	</ul>
</li>
	<li id="menu-item-149188" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149188 bgnav"><a href="/kontakt">Leserservice &#038; Kontakt</a></li>
	<li id="menu-item-149189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149189 bgnav"><a href="/autor-werden">Autor werden</a></li>
	<li id="menu-item-152084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152084 bgnav"><a href="https://entwickler.de/digital-lesen">Digital lesen</a></li>
	<li id="menu-item-149190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149190 bgnav"><a href="/anzeigenservice">Werbung</a></li>
	<li id="menu-item-149192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149192 bgnav"><a href="https://entwickler.de/social-media-uebersicht">Social Media</a></li>
	<li id="menu-item-149274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149274 bgnav"><a href="https://entwickler.de/redaktion">Die Redaktion</a></li>
</ul>
</li>
</ul>            <div class="right-nav">

        <ul class="right-menu menu">
        <li>
            <a href="#"><i class="fa fa-user"></i></a>
                        <ul>
                <li class="toplogin">
                    <a href="https://entwickler.de/my-account">Anmelden &amp; Registrieren</a>
                </li>
            </ul>
                    </li>
        <li><a href="#"><i class="fa fa-shopping-cart"></i></a>
            <ul class="topcart"></ul>
        </li>
    </ul>
    
            <ul class="top-socials">
            <li><a target='_blank' href='https://entwickler.de/feed/rss2'><i class='fa fa-rss'></i></a></li>        </ul><!-- /.top-socials -->
                <div class="top-search no-active">
            <a href="#" class="top-search-toggle"><i class="fa fa-search"></i></a>
            <form method="get" class="search-form" action="https://entwickler.de/">
    <input type="text" autocomplete="off" name="s" placeholder="Suchbegriff eingeben und Enter drücken">
    <button type="submit" name="button"><i data-loading="fa fa-spinner fa-spin" data-normal="fa fa-search" class="fa fa-search"></i></button>
</form>            <div class="search-result">
                <div class="search-result-wrapper">

                </div>
                <div class="search-noresult">
                    Kein Ergebnis                </div>
                <div class="search-all-button">
                    Alle Ergebnisse                </div>
            </div>
        </div>
    </div><!-- /.right-nav -->        </nav>
        <a href="#" class="mobile-toggle menu-toggle"><i class="fa fa-navicon"></i></a>
    
  			<style>
			@media only screen and (min-width: 1200px){
				.header-style-1 {height: 100px;}
			}
			</style>
			<div class="col-xs-12 online-sub-navbar-block visible-lg">
			<div id="nav_menu-15" class="widget widget_nav_menu"><div class="menu-entwickler-online-cat-sub-navi-container"><ul id="menu-entwickler-online-cat-sub-navi-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255830"><a href="https://entwickler.de/online/php">PHP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255831"><a href="https://entwickler.de/online/windowsdeveloper">Windows Developer</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255832"><a href="https://entwickler.de/online/mobile">Mobile</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255833"><a href="https://entwickler.de/online/javascript">JavaScript</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255839"><a href="https://entwickler.de/online/iot">IoT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-255834"><a href="https://entwickler.de/online/development">Development</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255843"><a href="https://entwickler.de/online/agile">Agile</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261621"><a href="https://entwickler.de/online/tools">Tools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255842"><a href="https://entwickler.de/online/ux">UX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255836"><a href="https://entwickler.de/online/web">Web</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255835"><a href="https://entwickler.de/online/webmagazin">WebMagazin</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-270629"><a href="https://entwickler.de/tag/.net">.NET</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-274742"><a href="https://entwickler.de/tv">entwickler.tv</a></li>
</ul></div></div>			</div>
	
			 </div> </header><aside id="sidebar">
    <section class="sands-sidebar-posts"> 
        <div class="sidebar-post-wrapper">
            <h2 class="sidebar-heading">Aktuelle Beiträge</h2>
            <div class='active sidebar-post-item clearfix ' data-id='579796021'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/development/microservices-trends-2017-579796021.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/04/Untitled-90x45.jpg' alt='Microservices-Trends 2017: Strategien, Tools &#038; Frameworks'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/development/microservices-trends-2017-579796021.html'>Microservices-Trends 2017: Strategien, Tools &#038; Frameworks</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/development' rel='category'>Development</a></span><br /><time class='' datetime='2017-04-12 13:51:10'>seit 2 Stunden online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix ' data-id='579796008'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/development/google-cloud-machine-learning-meteor-579796008.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/04/shutterstock_522119488-90x45.jpg' alt='Fast Forward: Updates für Googles Cloud Machine Learning &#038; Meteor 1.4.4'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/development/google-cloud-machine-learning-meteor-579796008.html'>Fast Forward: Updates für Googles Cloud Machine Learning &#038; Meteor 1.4.4</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/development' rel='category'>Development</a></span><br /><time class='' datetime='2017-04-12 15:21:49'>seit 50 Minuten online</time>
                        </footer>
                    </div>
                </div><div class='sidebar-post-item sidebar-promotion clearfix'><!-- entwickler.de_contentAD1_Wordpress -->

<div id='div-gpt-ad-1423481258370-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-0'); });
</script>
</div>


<!-- <h2 class="sidebar-heading">Top Jobs</h2>
<div style="margin:0 0 0 14px">
<h2 style="font-weight:700; margin-bottom:15px; font-size:17px"><a style="color:#000;" href="https://entwickler.de/wp-content/uploads/2016/01/Software-ArchitektmwfürMaterialfluss-und-Intralogistikprojekte.pdf">Software-Architekt (m/w)</a></h2>
<a style="color:#000;" href="https://entwickler.de/wp-content/uploads/2016/01/Software-ArchitektmwfürMaterialfluss-und-Intralogistikprojekte.pdf"><img style="margin-bottom:10px;" src="https://entwickler.de/wp-content/uploads/2016/01/vanderlande.jpg" alt="VANDERLANDE" title="VANDERLANDE"  width="150"/></a>
</div>--></div><div class=' sidebar-post-item clearfix ' data-id='579792873'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/web/flexbox-css3-html5-grid-579792873.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/03/shutterstock_154930787-90x45.jpg' alt='Flexbox im Einsatz'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/web/flexbox-css3-html5-grid-579792873.html'>Flexbox im Einsatz</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/web' rel='category'>Web</a></span><br /><time class='' datetime='2017-04-12 11:58:00'>seit 4 Stunden online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix ' data-id='579758145'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/windowsdeveloper/cognitive-services-recommendations-api-579758145.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2016/12/WD-AUFMACHER-SCHARCHL-90x45.jpg' alt='Das könnte Ihnen auch gefallen: Das Recommendations-API'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/windowsdeveloper/cognitive-services-recommendations-api-579758145.html'>Das könnte Ihnen auch gefallen: Das Recommendations-API</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/windowsdeveloper' rel='category'>Windows Developer</a></span><br /><time class='' datetime='2017-04-12 10:08:00'>seit 6 Stunden online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix ' data-id='579793095'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/development/women-in-tech-margret-hesselmann-579793095.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/03/Women_in_Tech_Aufmacher_900x450_39593_Margret_Hesselmann-90x45.jpg' alt='Women in Tech – &#8222;Wir brauchen mehr weibliche Vorbilder in der IT&#8220;'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/development/women-in-tech-margret-hesselmann-579793095.html'>Women in Tech – &#8222;Wir brauchen mehr weibliche Vorbilder in der IT&#8220;</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/development' rel='category'>Development</a></span><br /><time class='' datetime='2017-04-12 08:51:13'>seit 7 Stunden online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix ' data-id='579795820'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/development/android-o-security-fixes-typo3-extensions-579795820.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/04/shutterstock_572741317-90x45.jpg' alt='Fast Forward: Neues in Android O &#038; Security-Fixes für TYPO3-Extensions'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/development/android-o-security-fixes-typo3-extensions-579795820.html'>Fast Forward: Neues in Android O &#038; Security-Fixes für TYPO3-Extensions</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/development' rel='category'>Development</a></span><br /><time class='' datetime='2017-04-11 16:02:35'>seit 1 Tag online</time>
                        </footer>
                    </div>
                </div>        </div>
				
					<div class="sidebar-post-item clearfix sidebar-custom-ad-block">
			 
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-16" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<!-- entwickler.de_contentAD2_Wordpress -->
<div id='div-gpt-ad-1423481258370-1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-1'); });
</script>
</div>
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
			</div>
				<div class="sidebar-post-item clearfix sidebaradditional">
		 <div id="text-23" class="widget widget_text">			<div class="textwidget"><strong>Weitere Themenkategorien:</strong></div>
		</div><div id="nav_menu-13" class="widget widget_nav_menu"><div class="menu-entwickler-online-container"><ul id="menu-entwickler-online" class="menu"><li id="menu-item-163505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163505"><a href="https://entwickler.de/online/tools">• Tools</a></li>
<li id="menu-item-171666" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171666"><a href="https://entwickler.de/online/security">• Security</a></li>
<li id="menu-item-164602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164602"><a title="Alles rund um Docker" href="https://entwickler.de/tag/docker">• Docker</a></li>
<li id="menu-item-112703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112703"><a href="https://entwickler.de/online/datenbanken">• Datenbanken</a></li>
<li id="menu-item-168331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-168331"><a href="https://entwickler.de/online/cloud">• Cloud</a></li>
<li id="menu-item-168884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-168884"><a href="https://entwickler.de/windows-10-special">• Windows-10-Special</a></li>
</ul></div></div><div id="text-22" class="widget widget_text">			<div class="textwidget"><p>&nbsp;</p></div>
		</div>		</div>
    </section>

    <div class="sidebar-footer">
        <footer class="bottom">
            <p class="copyright"></p>
        </footer>
    </div>
</aside>
<div id="main">

<div class="section-wrap">
    <div class="wrapper">
            <div id="top-promotion">
        <div class="dfp-banner-show-only-on-desktop">
<!-- entwickler.de_leaderboard_Wordpress -->
            <div id='div-gpt-ad-1423481258370-5' style='width:100%; height:90px; margin-left: 30px;'>
            <script type='text/javascript'>
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-5'); });
            </script>
            </div>
</div>
    </div>
    


<div id="content" class="container">
    <article class="clearfix post-579796021 post type-post status-publish format-standard has-post-thumbnail hentry category-development tag-agile-2 tag-cloud tag-container tag-continuous-delivery tag-devops tag-domain-driven-design tag-microservices tag-umfrage" itemscope itemtype="http://schema.org/article">
        <header class="post-header clearfix">
        <div class="post-top-meta clearfix">
        <div class="breadcrumb" prefix="v: http://rdf.data-vocabulary.org/#"><span class="breadcrumb-item home-breadcrumb" typeof="v:Breadcrumb"><a href='https://entwickler.de' rel="v:url" property="v:title">Start</a></span><span class="breadcrumb-item" typeof="v:Breadcrumb"><a href='https://entwickler.de/online' rel="v:url" property="v:title"> Online</a></span><span class="breadcrumb-item" typeof="v:Breadcrumb"><a href='https://entwickler.de/online/development' rel="v:url" property="v:title"> Development</a></span></div>        <div class="post-date">
            <time class="post-date" itemprop="dateCreated" datetime="2017-04-12 13:51:10">Mittwoch, 12. April 2017</time>
            <meta itemprop="datePublished" content="2017-04-12 13:51:10">
        </div>
		    </div>
        <div class="post-header-container">
		
	
	               <h1 class="tagline h1-looks-like-tagline" itemprop="headline">Ergebnisse der Microservices-Umfrage</h1>
        	
        <div class="post-title h1-post-title" itemprop="name">Microservices-Trends 2017: Strategien, Tools &#038; Frameworks</div>
                    <div class="post-bottom-meta">
                				<span class="post-author"><a itemprop="author" href="https://entwickler.de/author/hartmutschlosser">Hartmut Schlosser</a> </span>                <time class="post-date" itemprop="dateCreated" datetime="2017-04-12 13:51:10">2 Stunden online</time>
                <span class="post-total-comment"><a href="#comments">Kommentare</a></span>            </div>
                
                    <div class="excerpt">
                <p>Microservices gehören zu den wichtigsten neuen Architektur-Konzepten. Doch weshalb sind Entwickler von Microservices überzeugt? Wir schauen uns die Gründe an, die die Teilnehmer unserer Rethink-IT-Umfrage angegeben haben. Auch Tools und Frameworks für Microservices kommen dabei nicht zu kurz&#8230;</p>
            </div>
            </div>
</header>

            <div class="col-sm-8 col-md-8">
            <figure class='featured featured-image'>
                        <img itemprop='image' src='https://entwickler.de/wp-content/uploads/2017/04/Untitled-900x450.jpg' alt='Microservices-Trends 2017: Strategien, Tools &#038; Frameworks'>
                        <p class='wp-caption-text'>© Shutterstock / otallypic</p>
                    </figure>            </div>


            <div class="social-icons hidden-xs col-md-1"><section class="sands-article-sharer section">
    <div class="socials-share">
        <a target="_blank" data-shareto="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://entwickler.de/?p=579796021" class="social-share share-facebook">
            <i class="fa fa-facebook"></i>
        </a>
        <a target="_blank" data-shareto="Twitter" href="https://twitter.com/home?status=Ich+empfehle+diesen+Artikel%3A+https%3A%2F%2Fentwickler.de%2F%3Fp%3D579796021" class="social-share share-twitter">
            <i class="fa fa-twitter"></i>
        </a>
        <a target="_blank" data-shareto="Google" href="https://plus.google.com/share?url=https://entwickler.de/?p=579796021" class="social-share share-google-plus">
            <i class="fa fa-google-plus"></i>
        </a>
        <a target="_blank" data-shareto="XING" href="https://www.xing.com/spi/shares/new?url=https://entwickler.de/?p=579796021&amp;title=&amp;description=Microservices+geh%C3%B6ren+zu+den+wichtigsten+neuen+Architektur-Konzepten.+Doch+weshalb+sind+Entwickler+von+Microservices+%C3%BCberzeugt%3F+Wir+schauen+uns+die+Gr%C3%BCnde+an%2C+die+die+Teilnehmer+unserer+Rethink-IT-Umfrage+angegeben+haben.+Auch+Tools+und+Frameworks+f%C3%BCr+Microservices+kommen+dabei+nicht+zu+kurz...&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-xing">
            <i class="fa fa-xing"></i>
        </a>
        <a target="_blank" data-shareto="Linked In" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://entwickler.de/?p=579796021&amp;title=&amp;summary=Microservices+geh%C3%B6ren+zu+den+wichtigsten+neuen+Architektur-Konzepten.+Doch+weshalb+sind+Entwickler+von+Microservices+%C3%BCberzeugt%3F+Wir+schauen+uns+die+Gr%C3%BCnde+an%2C+die+die+Teilnehmer+unserer+Rethink-IT-Umfrage+angegeben+haben.+Auch+Tools+und+Frameworks+f%C3%BCr+Microservices+kommen+dabei+nicht+zu+kurz...&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-linkedin">
            <i class="fa fa-linkedin"></i>
        </a>
    </div>
    <!--<div class="article-shorturl">
        <input type="text" id="shorturl" class="shorturl" data-clipboard-text="https://entwickler.de/?p=579796021" value="https://entwickler.de/?p=579796021">
    </div>-->
</section>
<div class="dummy-share-block"></div></div>
            <div class="clearfix"></div>

            <section class="article-content">

                <aside class="aside-post hidden-xs">
                <div class='yarpp-related'>
<h6 class="aside-heading">Mehr zum Thema</h6>
<div class="row yarpp-sands">
<div class='yarpp-sands-item'><a href='https://entwickler.de/online/development/umfrage-continuous-delivery-microservices-container-unternehmenskultur-300144.html' title='Große entwickler.de-Umfrage: Rethink IT &#8211; Continuous Delivery, Microservices, Container, Cloud, Unternehmenskultur'>
<div class='col-xs-12 yarpp-sands-image'><img width="230" height="115" src="https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-230x115.jpg" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="umfrage-rethink-it" srcset="https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-230x115.jpg 230w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-120x60.jpg 120w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-768x384.jpg 768w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-150x75.jpg 150w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-90x45.jpg 90w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-200x100.jpg 200w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-220x110.jpg 220w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-300x150.jpg 300w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-600x300.jpg 600w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it.jpg 900w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-350x175.jpg 350w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-110x55.jpg 110w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-72x36.jpg 72w, https://entwickler.de/wp-content/uploads/2016/10/umfrage-rethink-it-400x200.jpg 400w" sizes="(max-width: 230px) 100vw, 230px" /></div>
<div class="col-xs-12 yarpp-sands-headline"><div class="yarpp-sands-thumbnail-title">Große entwickler.de-Umfrage: Rethink IT &#8211; Continuous Delivery, Microservices, Container, Cloud, Unternehmenskultur</div></div></a>
</div>
</div>
<div class='clear'></div>
</div>
            </aside>
    	<h2>Rethink IT: Microservices!</h2>
<p>Wie stark sind moderne IT-Konzepte wie <strong>Microservices</strong>, <strong>Continuous Delivery</strong>, <strong>Cloud</strong>-Plattformen und <strong>Container</strong>-Technologien in der Praxis angekommen? Mit dieser Fragestellung beschäftigt sich unsere Umfrage <a href="https://entwickler.de/online/development/umfrage-continuous-delivery-microservices-container-unternehmenskultur-300144.html" target="_blank">Rethink IT </a>.</p>
<p><strong>Die Umfrage läuft noch bis Ende der Woche &#8211; machen Sie also mit!</strong></p>
<p>Wir schauen uns derweil spannende Zwischenergebnisse an &#8211; und beginnen mit dem Thema <strong>Microservices</strong>!</p>
<div class="boxed">
<p><strong><br />
<img class="size-full wp-image-579796035 alignleft" src="https://entwickler.de/wp-content/uploads/2017/04/Rethink-IT-Survey-300x180-1-150x90.jpg" alt="" width="150" height="90" srcset="https://entwickler.de/wp-content/uploads/2017/04/Rethink-IT-Survey-300x180-1-150x90.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/Rethink-IT-Survey-300x180-1-150x90-120x72.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/Rethink-IT-Survey-300x180-1-150x90-90x54.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/Rethink-IT-Survey-300x180-1-150x90-110x66.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/Rethink-IT-Survey-300x180-1-150x90-72x43.jpg 72w" sizes="(max-width: 150px) 100vw, 150px" />Microservices – Wie sieht es bei Euch aus? </strong><br />
In unserer Rethink-IT-Umfrage könnt Ihr klarstellen, ob und wie Microservices, Container, Cloud &amp; Co in Euren Unternehmen angekommen sind.</p>
<p><strong>Macht mit!</strong></p>
<p><a href="https://entwickler.de/online/development/umfrage-continuous-delivery-microservices-container-unternehmenskultur-300144.html"><img class="aligncenter wp-image-579796024" src="https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices.jpg" alt="" width="519" height="360" srcset="https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices.jpg 671w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-115x80.jpg 115w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-150x104.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-90x62.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-200x139.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-220x152.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-87x60.jpg 87w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-289x200.jpg 289w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-300x208.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-577x400.jpg 577w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-350x243.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-110x76.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-72x50.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/2Rethink-IT-Survey-Microservices-230x159.jpg 230w" sizes="(max-width: 519px) 100vw, 519px" /></a></p>
</div>
<h2>Microservices-Trends 2017 &#8211; der Zwischenstand</h2>
<p>Wir beginnen mit der Frage nach der <strong>Praxis-Relevanz von Microservices</strong>. Unter den Teilnehmern der Rethink-IT-Umfrage sind Microservices bereits ein wichtiges Thema. Lediglich 23,9% gaben an, mit Microservices nichts zu tun zu haben.</p>
<p>Die meisten Teilnehmer (35,8%) fahren eine Doppelstrategie: Existierende monolithische Anwendungen laufen zwar weiter, werden aber durch neue Komponenten ergänzt, die dann im Microservices-Stil gebaut werden:</p>
<p><img class="size-full wp-image-579796025 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0.jpg" alt="" width="715" height="345" srcset="https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0.jpg 715w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-120x58.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-150x72.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-90x43.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-200x97.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-220x106.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-300x145.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-600x290.jpg 600w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-350x169.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-110x53.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-72x35.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-414x200.jpg 414w, https://entwickler.de/wp-content/uploads/2017/04/3Microservices-Trends-Chart-0-230x111.jpg 230w" sizes="(max-width: 715px) 100vw, 715px" />Wo sehen die Umfragen-Teilnehmer die größten Vorteile von Microservices?</p>
<h2>Microservices sind interessant für mich weil&#8230;</h2>
<p>Wir haben die Teilnehmer gebeten, die Gründe für ihr Interesse an Microservices genauer zu evaluieren. Dabei galt es, den Grad ihrer Zustimmung für sieben vorgegebene Optionen anzugeben.</p>
<h3>Deployment</h3>
<p>Die größte Zustimmung erntete dabei der Vorteil von Microservices, beim Deployment eines neuen Features nicht die ganze Anwendung, sondern nur den <strong>entsprechenden Service deployen zu müssen</strong>.</p>
<p>51% der Teilnehmer stimmen hier voll zu, bei 27,6% ist die Zustimmung immer noch stark:</p>
<h3>Microservices are interesting for me because&#8230;</h3>
<p><img class="size-full wp-image-579796026 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5.jpg" alt="" width="521" height="328" srcset="https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5.jpg 521w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-120x76.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-150x94.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-90x57.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-200x126.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-220x139.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-300x189.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-350x220.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-110x69.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-72x45.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-318x200.jpg 318w, https://entwickler.de/wp-content/uploads/2017/04/4Microservices-Chart-5-230x145.jpg 230w" sizes="(max-width: 521px) 100vw, 521px" /></p>
<h3>Lose Koppelung</h3>
<p>Hoch geschätzt werden zudem die Eigenschaften von Microservices-Architekturen, zu<strong> lose gekoppelten Systemen</strong> mit unabhängigen Modulen zu führen.</p>
<h3><img class="size-full wp-image-579796027 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1.jpg" alt="" width="474" height="335" srcset="https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1.jpg 474w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-113x80.jpg 113w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-150x106.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-90x65.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-200x141.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-220x155.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-85x60.jpg 85w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-283x200.jpg 283w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-300x212.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-350x247.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-110x78.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-72x51.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/5Microservices-Chart-1-230x163.jpg 230w" sizes="(max-width: 474px) 100vw, 474px" /></h3>
<h3>Teamwork</h3>
<p>Dass Microservices auch positive Auswirkungen auf die Team-Strukturen haben können, ist ein weiterer Grund für das Interesse an diesem Ansatz. Der klar umrissene Scope von kleinen Services erleichtert die <strong>effiziente Team-Arbeit</strong>, was 39,6% der Umfrageteilnehmer an Microservices spannend finden:</p>
<h3><img class="size-full wp-image-579796028 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4.jpg" alt="" width="494" height="322" srcset="https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4.jpg 494w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-120x78.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-150x98.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-90x59.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-200x130.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-220x143.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-300x196.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-350x228.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-110x72.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-72x47.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-307x200.jpg 307w, https://entwickler.de/wp-content/uploads/2017/04/6Microservices-Chart-4-230x150.jpg 230w" sizes="(max-width: 494px) 100vw, 494px" /></h3>
<h3>Domain-driven Design</h3>
<p>Damit zusammenhängend ist die Möglichkeit, Anwendungen in <strong>domänenspezifische Einheiten</strong> zu unterteilen. Diese Option erhielt eine ähnlich hohe Zustimmung in der Umfrage:</p>
<p><img class="size-full wp-image-579796029 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04.png" alt="" width="469" height="313" srcset="https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04.png 469w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-120x80.png 120w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-150x100.png 150w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-90x60.png 90w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-200x133.png 200w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-220x147.png 220w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-300x200.png 300w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-350x234.png 350w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-110x73.png 110w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-72x48.png 72w, https://entwickler.de/wp-content/uploads/2017/04/7Bildschirmfoto-2017-04-11-um-10.45.04-230x153.png 230w" sizes="(max-width: 469px) 100vw, 469px" /></p>
<h3>Resilient, Technologie-agnostisch, wartbar</h3>
<p>Die restlichen drei Optionen erhielten weniger hohe Zustimmungswerte: Die Erhöhung der <strong>Ausfallsicherheit</strong> einer Anwendung, die Möglichkeit, in<strong> jedem Service eine andere Technologien</strong> zu nutzen, sowie <strong>Probleme mit der Wartung einer monolithischen Anwendung</strong>.</p>
<p><img class="size-full wp-image-579796030 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6.jpg" alt="" width="510" height="333" srcset="https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6.jpg 510w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-120x78.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-150x98.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-90x59.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-200x131.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-220x144.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-300x196.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-350x229.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-110x72.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-72x47.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-306x200.jpg 306w, https://entwickler.de/wp-content/uploads/2017/04/8Microservices-Chart-6-230x150.jpg 230w" sizes="(max-width: 510px) 100vw, 510px" /><img class="size-full wp-image-579796031 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2.jpg" alt="" width="500" height="329" srcset="https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2.jpg 500w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-120x80.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-150x99.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-90x59.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-200x132.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-220x145.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-300x197.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-350x230.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-110x72.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-72x47.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-304x200.jpg 304w, https://entwickler.de/wp-content/uploads/2017/04/9Microservices-Chart-2-230x151.jpg 230w" sizes="(max-width: 500px) 100vw, 500px" /></p>
<p><img class="size-full wp-image-579796032 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7.jpg" alt="" width="493" height="325" srcset="https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7.jpg 493w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-120x80.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-150x99.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-90x59.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-200x132.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-220x145.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-300x198.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-350x231.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-110x73.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-72x47.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-303x200.jpg 303w, https://entwickler.de/wp-content/uploads/2017/04/10Microservices-Chart-7-230x152.jpg 230w" sizes="(max-width: 493px) 100vw, 493px" /></p>
<h2>Domain-driven Design &amp; Microservices</h2>
<p><strong>Domain-driven Design</strong> ist so etwas wie der große Bruder von Microservices. Die Konzepte, die Anfang der 1990er von Eric Evans und anderen geprägt wurden, feiern im Zuge der Microservices-Debatten ein Comeback.</p>
<p>Auch die Umfrage zeigt, dass ein stärkerer Einbezug der Fachlichkeit in die Architektur-Überlegungen zu den wichtigsten Gründen für Microservices gehört (siehe oben). Wie weit Domain-driven Design bereits bei der Anwendungsentwicklung berücksichtigt wird, zeigt folgendes Schaubild:</p>
<p><img class="size-full wp-image-579796033 aligncenter" src="https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart.jpg" alt="" width="708" height="369" srcset="https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart.jpg 708w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-120x63.jpg 120w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-150x78.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-90x47.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-200x104.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-220x115.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-300x156.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-600x313.jpg 600w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-350x182.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-110x57.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-72x38.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-384x200.jpg 384w, https://entwickler.de/wp-content/uploads/2017/04/12Domain-driven-Design-Chart-230x120.jpg 230w" sizes="(max-width: 708px) 100vw, 708px" /></p>
<h2>Tools &amp; Frameworks für Microservices</h2>
<p>Kommen wir zum Schluss zu den konkreten Technologien, mit denen Microservices-Anwendungen gebaut werden. Hier gibt es einen klaren Sieger: 48,1% der Teilnehmer nutzen <strong>Spring Boot</strong> für ihre Microservices.</p>
<p><img class="aligncenter wp-image-579796034 size-full" src="https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools.jpg" alt="Microservices Trends 2017 - Chart" width="704" height="582" srcset="https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools.jpg 704w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-97x80.jpg 97w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-150x124.jpg 150w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-90x74.jpg 90w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-200x165.jpg 200w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-220x182.jpg 220w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-73x60.jpg 73w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-242x200.jpg 242w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-300x248.jpg 300w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-484x400.jpg 484w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-350x289.jpg 350w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-110x91.jpg 110w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-72x60.jpg 72w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-79x65.jpg 79w, https://entwickler.de/wp-content/uploads/2017/04/13Microservices-Frameworks-Tools-230x190.jpg 230w" sizes="(max-width: 704px) 100vw, 704px" /></p>
<p>Überraschend dicht folgt <strong>Java EE</strong> mit 44,3% der Teilnehmer. Dass sich die bewährten Standard-Technologien für Java-Enterprise-Anwendungen auch modernen Architektur-Paradigmen anpassen können, wurde ja bereits mehrfach in Artikeln und Konferenz-Talks bei den Kollegen von JAXenter thematisiert:</p>
<blockquote data-secret="57x7JjkssO" class="wp-embedded-content"><p><a href="https://jaxenter.de/java-ee-microservices-interview-46837">&#8222;Java EE und Microservices – rein technologisch spricht nichts gegen dieses Duo&#8220;</a></p></blockquote>
<p><iframe class="wp-embedded-content" sandbox="allow-scripts" security="restricted" style="position: absolute; clip: rect(1px, 1px, 1px, 1px);" src="https://jaxenter.de/java-ee-microservices-interview-46837/embed#?secret=57x7JjkssO" data-secret="57x7JjkssO" width="500" height="282" title="&#8222;&#8222;Java EE und Microservices – rein technologisch spricht nichts gegen dieses Duo&#8220;&#8220; &#8212; JAXenter" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
<p>Wenn es der Java EE-Gemeinde in den kommenden Versionen gelingt, die Unterstützung für Microservices weiter zu treiben, könnte sich die Waagschale sogar noch weiter in Richtung Java EE bewegen.</p>
<p>Stark schneiden auch das Monitoring Tool <strong>Prometheus</strong> (17,9%) sowie die Netflix Library <strong>Hystrix</strong> (17%) ab. Die extreme Microservices-Variante nach dem <strong>Serverless</strong>-Prinzip wird noch von einer Minderheit umgesetzt: <strong>AWS Lambda</strong> (7,5%), <strong>Azure Functions</strong> (2,8%), <strong>Serverless Framework</strong> (2,8%), <strong>Google Cloud Functions</strong> (2,8%).</p>
<h2 id="umfrage">Mitmachen!</h2>
<p>Wie erwähnt ist die Umfrage noch nicht abgeschlossen &#8211; machen Sie also mit und teilen Sie uns Ihre Einstellung zu Microservices und anderen Themen wie Continuous Delivery, Cloud und Container-Technologien mit!</p>
<p>Wir sind gespannt!<br />
<iframe src="https://docs.google.com/forms/d/e/1FAIpQLSc36Ly9vLO_8H44hX-6wVJ_geON7_hKl6dDOToCPJ5chpBqsw/viewform?embedded=true" width="740" height="2500" frameborder="0" marginwidth="0" marginheight="0">Loading&#8230;</iframe></p>
<p>&nbsp;</p>

            <div class="visible-xs col-xs-12"><section class="sands-article-sharer section">
    <div class="socials-share">
        <a target="_blank" data-shareto="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://entwickler.de/?p=579796021" class="social-share share-facebook">
            <i class="fa fa-facebook"></i>
        </a>
        <a target="_blank" data-shareto="Twitter" href="https://twitter.com/home?status=Ich+empfehle+diesen+Artikel%3A+https%3A%2F%2Fentwickler.de%2F%3Fp%3D579796021" class="social-share share-twitter">
            <i class="fa fa-twitter"></i>
        </a>
        <a target="_blank" data-shareto="Google" href="https://plus.google.com/share?url=https://entwickler.de/?p=579796021" class="social-share share-google-plus">
            <i class="fa fa-google-plus"></i>
        </a>
        <a target="_blank" data-shareto="XING" href="https://www.xing.com/spi/shares/new?url=https://entwickler.de/?p=579796021&amp;title=&amp;description=Microservices+geh%C3%B6ren+zu+den+wichtigsten+neuen+Architektur-Konzepten.+Doch+weshalb+sind+Entwickler+von+Microservices+%C3%BCberzeugt%3F+Wir+schauen+uns+die+Gr%C3%BCnde+an%2C+die+die+Teilnehmer+unserer+Rethink-IT-Umfrage+angegeben+haben.+Auch+Tools+und+Frameworks+f%C3%BCr+Microservices+kommen+dabei+nicht+zu+kurz...&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-xing">
            <i class="fa fa-xing"></i>
        </a>
        <a target="_blank" data-shareto="Linked In" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://entwickler.de/?p=579796021&amp;title=&amp;summary=Microservices+geh%C3%B6ren+zu+den+wichtigsten+neuen+Architektur-Konzepten.+Doch+weshalb+sind+Entwickler+von+Microservices+%C3%BCberzeugt%3F+Wir+schauen+uns+die+Gr%C3%BCnde+an%2C+die+die+Teilnehmer+unserer+Rethink-IT-Umfrage+angegeben+haben.+Auch+Tools+und+Frameworks+f%C3%BCr+Microservices+kommen+dabei+nicht+zu+kurz...&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-linkedin">
            <i class="fa fa-linkedin"></i>
        </a>
    </div>
    <!--<div class="article-shorturl">
        <input type="text" id="shorturl" class="shorturl" data-clipboard-text="https://entwickler.de/?p=579796021" value="https://entwickler.de/?p=579796021">
    </div>-->
</section>
<div class="dummy-share-block"></div></div>
    
            <div class="clearfix"></div>
        <div class="article-tags">
            <a href="https://entwickler.de/tag/agile-2" rel="tag">agile</a><a href="https://entwickler.de/tag/cloud" rel="tag">cloud</a><a href="https://entwickler.de/tag/container" rel="tag">container</a><a href="https://entwickler.de/tag/continuous-delivery" rel="tag">continuous delivery</a><a href="https://entwickler.de/tag/devops" rel="tag">DevOps</a><a href="https://entwickler.de/tag/domain-driven-design" rel="tag">domain-driven design</a><a href="https://entwickler.de/tag/microservices" rel="tag">microservices</a><a href="https://entwickler.de/tag/umfrage" rel="tag">umfrage</a>        </div>
        <div id="end-content"></div>

</section>

<section class="popup-post">
    <strong class="popup-heading">Unsere Redaktion empfiehlt:</strong>
    <div class="popup-content">
                <figure class="thumb">
            <a href="https://entwickler.de/online/development/google-cloud-machine-learning-meteor-579796008.html"><img src="https://entwickler.de/wp-content/uploads/2017/04/shutterstock_522119488-90x45.jpg" alt=""></a>
        </figure>
                <h3 class="post-title"><a href="https://entwickler.de/online/development/google-cloud-machine-learning-meteor-579796008.html">Fast Forward: Updates für Googles Cloud Machine Learning &amp; Meteor 1.4.4</a></h3>
    </div>
    <a href="#" class="popup-close"><i class="fa fa-close"></i></a>
</section>


<section id="related-post" class="post-three-columns post-columns section">
    <div class="row clearfix">

        <div class="col-md-12 section-heading-wrapper">
            <h3 class="section-heading">Relevante <strong>Beiträge</strong></h3>
        </div>
    </div>

        <div class="row clearfix relatedfix">
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/development/google-cloud-machine-learning-meteor-579796008.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/04/shutterstock_522119488-300x150.jpg' alt='Fast Forward: Updates für Googles Cloud Machine Learning &#038; Meteor 1.4.4'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/development/google-cloud-machine-learning-meteor-579796008.html">Fast Forward: Updates für Googles Cloud Machine Learning &#038; Meteor 1.4.4</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/redaktion" rel="author">Redaktion</a>
                        </span>
                        <time class="post-date" datetime="2017-04-12 15:21:49">
                            50 Minuten online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/development/women-in-tech-margret-hesselmann-579793095.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/03/Women_in_Tech_Aufmacher_900x450_39593_Margret_Hesselmann-300x150.jpg' alt='Women in Tech – &#8222;Wir brauchen mehr weibliche Vorbilder in der IT&#8220;'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/development/women-in-tech-margret-hesselmann-579793095.html">Women in Tech – &#8222;Wir brauchen mehr weibliche Vorbilder in der IT&#8220;</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/mascha-schnellbacher" rel="author">Mascha Schnellbacher</a>
                        </span>
                        <time class="post-date" datetime="2017-04-12 08:51:13">
                            7 Stunden online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/development/android-o-security-fixes-typo3-extensions-579795820.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/04/shutterstock_572741317-300x150.jpg' alt='Fast Forward: Neues in Android O &#038; Security-Fixes für TYPO3-Extensions'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/development/android-o-security-fixes-typo3-extensions-579795820.html">Fast Forward: Neues in Android O &#038; Security-Fixes für TYPO3-Extensions</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/redaktion" rel="author">Redaktion</a>
                        </span>
                        <time class="post-date" datetime="2017-04-11 16:02:35">
                            1 Tag online                        </time>
                    </div>
                </header>
            </article>
        </div>
        </div> <!-- related fix --><div class="row clearfix relatedfix">
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/development/optimieren-datenzentrierte-apis-interview-579795723.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/04/shutterstock_548025055-1-300x150.jpg' alt='Optimieren von datenzentrierten APIs [Interview]'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/development/optimieren-datenzentrierte-apis-interview-579795723.html">Optimieren von datenzentrierten APIs [Interview]</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/mschrempp" rel="author">Mirko Schrempp</a>
                        </span>
                        <time class="post-date" datetime="2017-04-11 12:05:59">
                            1 Tag online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/development/rockstar-entwickler-tipps-579776511.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/02/shutterstock_273152309-300x150.jpg' alt='Rockstar werden: Das macht richtig gute Entwickler aus!'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/development/rockstar-entwickler-tipps-579776511.html">Rockstar werden: Das macht richtig gute Entwickler aus!</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/aklose" rel="author">Ann-Cathrin Klose</a>
                        </span>
                        <time class="post-date" datetime="2017-04-11 08:45:06">
                            1 Tag online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/development/angular-lts-react-v15-5-0-579795700.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/04/ff-angular-lts-react-15-5-0-300x150.jpg' alt='Fast Forward: Long-Term-Support für Angular &#038; React v15.5.0 ist erschienen'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/development/angular-lts-react-v15-5-0-579795700.html">Fast Forward: Long-Term-Support für Angular &#038; React v15.5.0 ist erschienen</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/redaktion" rel="author">Redaktion</a>
                        </span>
                        <time class="post-date" datetime="2017-04-10 16:01:02">
                            2 Tagen online                        </time>
                    </div>
                </header>
            </article>
        </div>
        </div> <!-- related fix -->
</section>


        <section id="comments" class="comment-wrapper section"><h3 class='comment-heading'>Meinungen zu diesem Beitrag</h3>            <div id="disqus_thread"></div>
        </section>    </article>
    <!-- Side Ads -->

  


<div id="sidecontent-promotion" class="container">
        <!-- entwickler.de_skyscraper1_Wordpress -->
                <div id='div-gpt-ad-1423481258370-6' class='skyad-right' style="margin-top: 21px;">
                <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-6'); });
                </script>
                </div>
</div>


</div>

                    <!-- FOOTER -->
<footer id="footer">
    <div id="footer-content" class="container clearfix">
                        <aside class="col-md-3 column"> <div class="footer-widget widget_nav_menu" id="nav_menu-9"><h2 class="widget-title">Online</h2><div class="menu-online-container"><ul id="menu-online" class="menu"><li id="menu-item-112715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112715"><a href="http://jaxenter.de">JAXenter.de</a></li>
<li id="menu-item-112716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112716"><a href="http://jaxenter.com">JAXenter.com</a></li>
</ul></div></div> </aside>
                <aside class="col-md-3 column"> <div class="footer-widget widget_nav_menu" id="nav_menu-10"><h2 class="widget-title">Magazine</h2><div class="menu-magazine-container"><ul id="menu-magazine" class="menu"><li id="menu-item-112718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112718"><a href="http://entwickler.de/php-magazin">PHP Magazin</a></li>
<li id="menu-item-112722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112722"><a href="http://windowsdeveloper.de/shop">Windows Developer</a></li>
<li id="menu-item-149283" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149283"><a href="http://entwickler.de/entwickler-magazin">Entwickler Magazin</a></li>
<li id="menu-item-149282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149282"><a href="http://entwickler.de/mobile-technology">Mobile Technology</a></li>
<li id="menu-item-112723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112723"><a href="http://windowsdeveloper.de/shop">SharePoint Kompendium</a></li>
<li id="menu-item-112719" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112719"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-112720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112720"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-112721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112721"><a href="https://jaxenter.de/magazine/business-technology">Business Technology</a></li>
</ul></div></div> </aside>
                <aside class="col-md-3 column"> <div class="footer-widget widget_nav_menu" id="nav_menu-11"><h2 class="widget-title">Konferenzen</h2><div class="menu-konferenzen-container"><ul id="menu-konferenzen" class="menu"><li id="menu-item-112724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112724"><a href="https://jax.de">JAX</a></li>
<li id="menu-item-112725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112725"><a href="https://basta.net">BASTA!</a></li>
<li id="menu-item-112726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112726"><a href="https://phpconference.com">International PHP Conference</a></li>
<li id="menu-item-112727" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112727"><a href="https://webtechcon.de">WebTech Conference</a></li>
<li id="menu-item-112728" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112728"><a href="https://webinale.de">webinale</a></li>
<li id="menu-item-112729" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112729"><a href="https://mobiletechcon.de/">MobileTech Conference</a></li>
<li id="menu-item-173190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-173190"><a href="https://iotcon.de/">Internet of Things Conference</a></li>
<li id="menu-item-173189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-173189"><a href="http://devopsconference.de/de/">DevOpsCon</a></li>
</ul></div></div> </aside>
                <aside class="col-md-3 column"> <div class="footer-widget">
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-15" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<p class="widget-title">S&S Media</p>
<div class="menu-konferenzen-container">
	<ul id="menu-konferenzen-4" class="menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113724"><a href="http://sandsmedia.com/de/unternehmen">Über S&amp;S Media</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113725"><a href="http://entwickler-akademie.de/">Entwickler Akademie</a></li>
	</ul>
</div>
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
 </div></aside>
            <aside class="col-md-12 column"> 
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-14" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<ul id="menu-footer-impressum" class="menu"><li id="menu-item-112731" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112731"><a href="http://sandsmedia.com/">Software &amp; Support Media GmbH</a></li>
<li id="menu-item-112732" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112732"><a href="/impressum">Impressum</a></li>
<li id="menu-item-112733" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112733"><a href="/datenschutz">Datenschutz</a></li>
<li id="menu-item-123344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-123344"><a href="/entwicklerde_agb">AGB</a></li>
<li id="menu-item-112842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112842"><a href="/lieferkonditionen">Lieferkonditionen</a></li>
</ul>
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
</aside>
    </div>
    <!-- /.footer-wrapper -->

    <div class="footer-bottom container center" >
	
                <p class="copyright"></p>
    </div>
    <!-- /.footer-bottom -->
</footer>
<!-- /#footer -->                    </div>
                    <div class="ajax-overlay">
                        <div id="postloader"></div>
                    </div>
                </div>
            </div>
                <div id="gmw-cl-form-wrapper" class="gmw-cl-form-wrapper"><span id="gmw-cl-close-btn">X</span><form id="gmw-cl-form" name="gmw_cl_form" onsubmit="return false"><div id="gmw-cl-info-wrapper"><div id="gmw-cl-location-message">- Gib Deinen Standort ein -</div><div id="gmw-cl-input-fields"><input type="text" name="gmw-cl_address" id="gmw-cl-address" value="" placeholder="zipcode or full address..." /><input id="gmw-cl-submit-address" type="submit" value="go" /></div><div> - or - </div><div id="gmw-cl-get-location"><a href="#" id="gmw-cl-trigger" >Erhalte Deinen aktuellen Standort</a></div></div><div id="gmw-cl-respond-wrapper" style="display:none;"><div id="gmw-cl-spinner"><img src="https://entwickler.de/wp-content/plugins/geo-my-wp/assets/images/gmw-loader.gif" /></div><div id="gmw-cl-message"></div><div id="gmw-cl-map" style="width:100%;height:100px;display:none;"></div></div></form></div><div id="gmw-cl-hidden-form-wrapper">
                    <form id="gmw-cl-hidden-form" method="post">
                        <input type="hidden" id="gmw-cl-street" 		   name="gmw_cl_location[street]" value="" />
                        <input type="hidden" id="gmw-cl-city"   		   name="gmw_cl_location[city]" value="" />
                        <input type="hidden" id="gmw-cl-state" 			   name="gmw_cl_location[state]" value="" />
                        <input type="hidden" id="gmw-cl-state-long" 	   name="gmw_cl_location[state_long]" value="" />
                        <input type="hidden" id="gmw-cl-zipcode" 		   name="gmw_cl_location[zipcode]" value="" />
                        <input type="hidden" id="gmw-cl-country" 		   name="gmw_cl_location[country]" value="" />
                        <input type="hidden" id="gmw-cl-country-long" 	   name="gmw_cl_location[country_long]" value="" />
                        <input type="hidden" id="gmw-cl-org-address" 	   name="gmw_cl_location[address]" value="" />
                        <input type="hidden" id="gmw-cl-formatted-address" name="gmw_cl_location[formatted_address]" value="" />
                        <input type="hidden" id="gmw-cl-lat" 			   name="gmw_cl_location[lat]" value="" />
                        <input type="hidden" id="gmw-cl-lng" 			   name="gmw_cl_location[lng]" value="" />
                        <input type="hidden" id="gmw-cl-action" 		   name="gmw_cl_action" value="post" />
                    </form>
                </div><script type="text/javascript">
jQuery(document).ready(function($) {

    //declare new map options array for form ID 1
    gmwMapOptions['1'] = []; 
    gmwMapOptions['1']['styles'] = [
    {
        "featureType": "landscape",
        "stylers": [
            {
                "color": "#f2f2f2"
            }
        ]
    },
    {
        "featureType": "road",
        "stylers": [
            {
                "saturation": -100
            },
            {
                "lightness": 45
            }
        ]
    },
    {
        "featureType": "road.highway",
        "stylers": [
            {
                "visibility": "simplified"
            }
        ]
    },
    {
        "featureType": "road.arterial",
        "elementType": "labels.icon",
        "stylers": [
            {
                "visibility": "off"
            }
        ]
    },
    {
        "featureType": "administrative",
        "elementType": "labels.text.fill",
        "stylers": [
            {
                "color": "#444444"
            }
        ]
    },
    {
        "featureType": "transit",
        "stylers": [
            {
                "visibility": "off"
            }
        ]
    },
    {
        "featureType": "poi",
        "stylers": [
            {
                "visibility": "off"
            }
        ]
    }
]
});
</script>
<style type="text/css">
            h2.frq-main-title{
               font-size: 18px;
            }
            .hrf-entry{
               border:none !important;
               margin-bottom: 0px !important;
               padding-bottom: 0px !important;
            }
            .hrf-content{
               display:none;
               color: #444444;
               background: #ffffff;
               font-size: 14px;
               padding: 10px;
               padding-left: 50px;
               word-break: normal;
            }
            h3.hrf-title{
               font-size: 18px ;
               color: #444444;
               background: #ffffff;
               padding: 10px ;
               padding-left: 50px;
               margin: 0;
               -webkit-touch-callout: none;
               -webkit-user-select: none;
               -khtml-user-select: none;
               -moz-user-select: none;
               -ms-user-select: none;
               user-select: none;
               outline-style:none;
            }
            .hrf-title.close-faq{
               cursor: pointer;
            }
            .hrf-title.close-faq span{
               width: 30px;
               height: 30px;
               display: inline-block;
               position: relative;
               left: 0;
               top: 8px;
               margin-right: 12px;
               margin-left: -42px;
               background: #444444 url(https://entwickler.de/wp-content/plugins/html5-responsive-faq/images/open.png) no-repeat center center;
            }
            }.hrf-title.open-faq{
            
            }
            .hrf-title.open-faq span{
               width: 30px;
               height: 30px;
               display: inline-block;
               position: relative;
               left: 0;
               top: 8px;
               margin-right: 12px;
               margin-left: -42px;
               background: #444444 url(https://entwickler.de/wp-content/plugins/html5-responsive-faq/images/close.png) no-repeat center center;
            }
            .hrf-entry p{
            
            }
            .hrf-entry ul{
            
            }
            .hrf-entry ul li{
            
            }</style>


    <div id="wpfront-scroll-top-container"><img src="https://entwickler.de/wp-content/plugins/wpfront-scroll-top/images/icons/1.png" alt="" /></div>
    <script type="text/javascript">function wpfront_scroll_top_init() {if(typeof wpfront_scroll_top == "function" && typeof jQuery !== "undefined") {wpfront_scroll_top({"scroll_offset":100,"button_width":0,"button_height":0,"button_opacity":0.8,"button_fade_duration":200,"scroll_duration":400,"location":1,"marginX":20,"marginY":20,"hide_iframe":false,"auto_hide":false,"auto_hide_after":2});} else {setTimeout(wpfront_scroll_top_init, 100);}}wpfront_scroll_top_init();</script>    <script></script>
    <script type="text/javascript">
	  jQuery(document).ready(function ($) {

//custom validation rule
$.validator.addMethod("customemail", 
    function(value, element) {
	return /^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$/.test(value);
    }, 
    "Sorry, I've enabled very strict email validation"
);


        $('#commentform').validate({
          rules: {
            author: {
              required: true,
              minlength: 2
            },
  //          email: {
  //            required: true,
  //            email: true
  //		},
	      email: {
                required:  {
                    depends:function(){
                        $(this).val($.trim($(this).val()));
                        return true;
                    }   
                },
                customemail: true
            },
            comment: {
              required: true,
              minlength: 1
            }
          },
          messages: {
            author: "Bitte geben Sie einen Namen an.",
            email: "Bitte geben Sie eine gültige Email-Adresse an.",
            comment: "Bitte geben Sie einen Kommentar an."
          },
          errorElement: "div",
          errorPlacement: function (error, element) {
            element.after(error);
          }

        });
      });
    </script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?x93936'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://entwickler.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?x93936' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='https://entwickler.de/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=230&#038;height=0&#038;ver=4.4' type='text/css' media='all' />
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/jquery.validate.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/dist/js/scripts.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands-jobbookmark-plugin/include/script.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands-jobbookmark-plugin/include/jquery.cookie.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands-top-article-slider/assets/top-article-slider.js?x93936'></script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/online\/development\/microservices-trends-2017-579796021.html?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?x93936'></script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/online\/development\/microservices-trends-2017-579796021.html?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};
/* ]]> */
</script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/wp-polls/polls-js.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"de-DE","strings":{"Close":"Schlie\u00dfen","Fullscreen":"Vollbild","Turn off Fullscreen":"Vollbild beenden","Go Fullscreen":"Vollbild einschalten","Download File":"Datei herunterladen","Download Video":"Video herunterladen","Play":"Abspielen","Pause":"Pause","Captions\/Subtitles":"Beschriftungen\/Untertitel","None":"None","Time Slider":"Zeit-Schieberegler","Skip back %1 seconds":"%1 Sekunde(n) zur\u00fcck springen","Video Player":"Video-Player","Audio Player":"Audio-Player","Volume Slider":"Lautst\u00e4rkeregler","Mute Toggle":"Stumm schalten","Unmute":"Laut schalten","Mute":"Stumm","Use Up\/Down Arrow keys to increase or decrease volume.":"Pfeiltasten Hoch\/Runter benutzen, um die Lautst\u00e4rke zu regeln.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Benutze die Pfeiltasten Links\/Rechts, um 1 Sekunde vorzuspringen, und die Pfeiltasten Hoch\/Runter, um 10 Sekunden vorzuspringen."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/mediaelement/mediaelement-and-player.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/mediaelement/wp-mediaelement.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/plugins.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/html5shiv.min.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jmagzoption = {"ajaxurl":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php","copyclipboard":" URL kopieren f\u00fcr clipboard","shareto":"Artikel teilen hit","gacode":"","usezoom":"1","ismobile":"","commentscript":"disqus","disqus_shortname":"entwicklermagazin","fbapps":"125823254276164","isie":"","postid":"579796021","isblog":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/main.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public//js/zeroclipboard/ZeroClipboard.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/ajax-post.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/comment-reply.min.js?x93936'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/wp-embed.min.js?x93936'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gmwSettings = {"general_settings":{"google_api":"AIzaSyA9QVPRKdNm3gpEd2_JmnD4n6U8tW2RFuk","js_geocode":"1","language_code":"DE","country_code":"DE","results_page":"191273","url_px":"gmw_","auto_locate":false},"post_types_settings":{"edit_post_zoom_level":"7","edit_post_latitude":"40.7115441","edit_post_longitude":"-74.01348689999998","post_types":["jobpost"]}};
var gmwMapOptions = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/geo-my-wp/assets/js/gmw.js?x93936'></script>
	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PJK98V"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-PJK98V');</script>
	<!-- End Google Tag Manager -->
    <script type="text/javascript">
    	</script>
    
	<!-- End Google Tag Manager -->
    </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced

 Served from: entwickler.de @ 2017-04-12 16:11:25 by W3 Total Cache -->