Dotdeb goes PHP 5.4: Preview Pakete für Debian 6.0 verfügbar
Kommentare

Ziemlich schnell hat man bei Dotdeb auf das Release von PHP Core 5.4 reagiert und erste Preview Packages für amd64 und i386 veröffentlicht. Da der Suhosin-Patch jedoch noch nicht verfügbar ist und manche

Ziemlich schnell hat man bei Dotdeb auf das Release von PHP Core 5.4 reagiert und erste Preview Packages für amd64 und i386 veröffentlicht. Da der Suhosin-Patch jedoch noch nicht verfügbar ist und manche Erweiterungen noch nicht richtig funktionieren oder gar fehlen, ist der produktive Einsatz noch nicht möglich.

Fehlende Pakete wie php5-ffmpeg,
php5-memcached,
php5-pinba,
php5-suhosin,
php5-xcache,
php5-xdebug
oder
php5-xhprof sollen in den kommenden Wochen im Repository nachgeliefert werden. Damit das Upgrade nicht automatisch erfolgt, wurde PHP 5.4 in einem alternativen Pfad freigegeben. Für die Installation muss also deb http://packages.dotdeb.org/ squeeze-php54 all zur sources.list von APT hinzugefügt werden. Die Veränderungen beziehen sich auf das An- und Abschalten von MySQL- und anderen Funktionalitäten:

  • if you need MySQL-related functions, you can now choose between the (libmysqlclient-linked) php5-mysql package and the (MySQL native – and better – driver-linked) php5-mysqlnd one
  • PHP extensions config files are now migrated to /etc/php5/mods-available/. Files in /etc/php5/conf.d/ are now just symlinks to them. Therefore, you can activate PHP extensions by using php5enmod/php5dismod.
Unsere Redaktion empfiehlt:

Relevante Beiträge

Meinungen zu diesem Beitrag

X
- Gib Deinen Standort ein -
- or -