Password-Hashing-API aus PHP 5.5 schon jetzt nutzen
Kommentare

Die Passwort-API aus PHP 5.5 soll sicheres Hashen von Passwörtern stark vereinfachen. Wer schon jetzt von der neuen Syntax profitieren möchte, dem sei das Kompatibilitäts-Paket von Anthony Ferrara ans

Die Passwort-API aus PHP 5.5 soll sicheres Hashen von Passwörtern stark vereinfachen. Wer schon jetzt von der neuen Syntax profitieren möchte, dem sei das Kompatibilitäts-Paket von Anthony Ferrara ans Herz gelegt. Es lässt sich einfach über den Composer einbinden.

Sobald PHP 5.5 erscheint, wird password_compat überflüssig, und Ihr könnt Euren Code dank der nativen Implementation von password_hash(&#36password, PASSWORD_DEFAULT) einfach weiterverwenden. Mehr Infos zum neuen API findet Ihr in GitHub. Ferraras Kompatibilitäts-Paket liegt hier. Und wenn Euch PHP 5.5 generell interessiert, haben wir hier einige der neuen Features vorgestellt.

Unsere Redaktion empfiehlt:

Relevante Beiträge

Meinungen zu diesem Beitrag

X
- Gib Deinen Standort ein -
- or -