PHP Versions Stats 2019.2 veröffentlicht

Die meistbenutzte PHP-Version: PHP 7.3 überholt 7.2
Keine Kommentare

Bereits seit 2014 erstellt Jordi Boggiano, Mitbegeründer von Private Packagist, einen halbjährlichen Report über die Verwendung diverser PHP-Versionen. Die Datenbasis bezieht er dabei aus den Composer-Installationen auf packagist.io. Im November 2019 überholt PHP 7.3 den Sieger PHP 7.2 vom Mai 2019.

Seit 2014 geht Jordi Boggiano, Mitbegeründer von Private Packagist, zwei Mal im Jahr auf die Suche nach der meistbenutzten Version der Programmiersprache PHP. Wir schauen auf die Ergebnisse der vor Kurzem veröffentlichten PHP Versions Stats 2019.2 von November 2019.

PHP 7.3 auf Platz 1 der meistbenutzen PHP-Versionen

Noch im Mai 2019 war PHP 7.2 mit 39,3 Prozent die Antwort auf die Frage nach der beliebtesten Version. Im November 2019 beansprucht PHP 7.3 den ersten Platz für sich. Noch im Mai lag die Nutzung von PHP 7.3 bei 15,5 Prozent. Im November 2019 ist eine Wachstum von 19,89 Prozent festzustellen, sodass PHP 7.3 mit 35,2 Prozent aktuell zur beliebtesten PHP-Version gehört.

PHP-Versionsverbreitung November 2019 vs. Mai 2019 (Quelle: https://blog.packagist.com/php-versions-stats-2019-2-edition/)

Für die 5.x-Versionen endete der Support bereits am 31. Dezember 2018 – das sagte die Community dazu. Laut der Statistik nutzen noch 9 Prozent eine veraltete und nicht mehr unterstützte 5.x-Version.

PHP 7.1 erreicht erst kürzlich, am 1. Dezember 2019 den End of Life (wir berichteten). Diese Version wurde im November 2019 noch von 15.3 Prozent der Nutzer verwendet. Im Vergleich zu den Ergebnissen von Mai 2019 sank hier die Nutzung um 10,32 Prozent.

Erst Ende November 2019 ist die aktuelle Version 7.4 von PHP erschienen. Hier liegt der Wert laut Statistik bei einer Nutzung von 2,92 Prozent, Tendenz steigend.

Lesen Sie auch: PHP 7.4 veröffentlicht – Der Guide zu den neuen Features

PHP Version Stats 2019.2: Die Datenbasis

Jordi Boggiano zieht die Daten aus den Composer-Installationen aus den Logs auf packagist.org. Denn der Composer gibt über den User-Agent Header bekannt, für welche PHP-Versionen die Nutzer den Composer verwenden. Dabei werden CI-Umgebungen nicht berücksichtigt. Insofern handelt es sich hierbei lediglich um einen Teil der PHP-Benutzerbasis.

Unsere Redaktion empfiehlt:

Relevante Beiträge

Hinterlasse einen Kommentar

Hinterlasse den ersten Kommentar!

avatar
400
  Subscribe  
Benachrichtige mich zu:
X
- Gib Deinen Standort ein -
- or -