Upgrade Warning für PHP 5.3.7
Kommentare

Haben wir euch am Freitag noch die frohe Kunde vom Erscheinen von PHP 5.3.7 verkündet, müssen wir heute schon wieder zurückrudern: Das Team hat eine Upgrade-Warnung herausgegeben. Wer noch nicht auf

Haben wir euch am Freitag noch die frohe Kunde vom Erscheinen von PHP 5.3.7 verkündet, müssen wir heute schon wieder zurückrudern: Das Team hat eine Upgrade-Warnung herausgegeben. Wer noch nicht auf die neueste Version umgestiegen ist, sollte sich noch ein wenig gedulden.

Due to unfortunate issues with 5.3.7 users should wait with upgrading until 5.3.8 will be released (expected in few days).PHP Core Team, 2011

Schuld an der Rückrufaktion ist der Bug mit der ID 55439. Wird crypt() mit einem MD5-Salt ausgeführt, wird nur der Wert des Salts zurückgegeben, nicht jedoch das erwartete Ergebnis. Die entsprechenden Funktionen für DES und Blowfish seien nicht davon betroffen.

Mit PHP 5.3.8 könnte jedoch bereits früher gerechnet werden, wie der Tweet von Pierre Joye verkündet:

the 5.3.7 break got a little announce now, http://t.co/dnymi9Y 5.3.8 to be available by tomorrow.less than a minute ago via TweetDeck Favorite Retweet Reply

Jetzt heißt es also abwarten mit dem updaten – wir halten euch natürlich auf dem Laufenden!

Unsere Redaktion empfiehlt:

Relevante Beiträge

Meinungen zu diesem Beitrag

X
- Gib Deinen Standort ein -
- or -