<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="de-DE" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="de-DE" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>

    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, maximum-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://entwickler.de/xmlrpc.php" />
    
    <script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
		var gads = document.createElement('script');
		gads.async = true;
		gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + 
		'//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
		})();
		</script>
		
		<script type='text/javascript'>
		googletag.cmd.push(function() {
		googletag.defineSlot('/21339274/entwickler.de_contentAD1_Wordpress', [300, 250], 'div-gpt-ad-1423481258370-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_contentAD2_Wordpress', [300, 250], 'div-gpt-ad-1423481258370-1').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_contentAD_Startpage_Wordpress', [300, 250], 'div-gpt-ad-1423481258370-2').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_FullsizeAD1_Wordpress', [468, 60], 'div-gpt-ad-1423481258370-3').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_leaderboard2_Wordpress', [728, 90], 'div-gpt-ad-1423481258370-4').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_leaderboard_Wordpress', [728, 90], 'div-gpt-ad-1423481258370-5').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_skyscraper1_Wordpress', [160, 600], 'div-gpt-ad-1423481258370-6').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de_skyscraper2_Wordpress', [160, 600], 'div-gpt-ad-1423481258370-7').addService(googletag.pubads());
		// HOCKEYSTICK
		googletag.defineSlot('/21339274/entwickler.de-hockeystick-right', [160, 600], 'div-gpt-ad-1472121133864-0').addService(googletag.pubads());
		googletag.defineSlot('/21339274/entwickler.de-hockeystick-top', [728, 90], 'div-gpt-ad-1472121133864-1').addService(googletag.pubads());
		googletag.pubads().collapseEmptyDivs(true);
		googletag.pubads().enableSingleRequest();
		googletag.enableServices();
		});
		</script>
		
    <title>Force Feedback Programming: Direktes Feedback für besseren Code</title>
<link rel="shortcut icon" type="image/x-icon" href="https://entwickler.de/wp-content/themes/entwicklerDE/public/img/favicon.ico" />
<!-- This site is optimized with the Yoast SEO plugin v3.4.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Force Feedback Programming für Visual Studio gibt Entwicklern direktes Feedback zur Qualität ihres Codes. Optisch und taktil!"/>
<meta name="news_keywords" content="basta!, clean code, force feedback, visual studio" />
<link rel="original-source" href="https://entwickler.de/online/windowsdeveloper/force-feedback-programming-visual-studio-579766435.html" />
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://entwickler.de/online/windowsdeveloper/force-feedback-programming-visual-studio-579766435.html" />
<link rel="publisher" href="https://plus.google.com/u/0/b/106823074878206058879/106823074878206058879/posts"/>
<meta property="og:locale" content="de_DE" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Force Feedback Programming: Direktes Feedback für besseren Code" />
<meta property="og:description" content="Force Feedback Programming für Visual Studio gibt Entwicklern direktes Feedback zur Qualität ihres Codes. Optisch und taktil!" />
<meta property="og:url" content="https://entwickler.de/online/windowsdeveloper/force-feedback-programming-visual-studio-579766435.html" />
<meta property="og:site_name" content="entwickler.de" />
<meta property="article:publisher" content="https://www.facebook.com/entwickler.de" />
<meta property="article:tag" content="basta!" />
<meta property="article:tag" content="clean code" />
<meta property="article:tag" content="force feedback" />
<meta property="article:tag" content="visual studio" />
<meta property="article:section" content="Windows Developer" />
<meta property="article:published_time" content="2017-01-24T11:55:34+01:00" />
<meta property="article:modified_time" content="2017-01-24T11:57:07+01:00" />
<meta property="og:updated_time" content="2017-01-24T11:57:07+01:00" />
<meta property="og:image" content="https://entwickler.de/wp-content/uploads/2017/01/shutterstock_165738023.jpg" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="450" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Force Feedback Programming für Visual Studio gibt Entwicklern direktes Feedback zur Qualität ihres Codes. Optisch und taktil!" />
<meta name="twitter:title" content="Force Feedback Programming: Direktes Feedback für besseren Code" />
<meta name="twitter:site" content="@entwickler" />
<meta name="twitter:image" content="https://entwickler.de/wp-content/uploads/2017/01/shutterstock_165738023.jpg" />
<meta name="twitter:creator" content="@entwickler" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maps.googleapis.com'>
<link rel='dns-prefetch' href='//fonts.googleapis.com'>
<link rel='dns-prefetch' href='//s.w.org'>
<link rel="alternate" type="application/rss+xml" title="entwickler.de &raquo; Feed" href="https://entwickler.de/feed" />
<link rel="alternate" type="application/rss+xml" title="entwickler.de &raquo; Kommentar-Feed" href="https://entwickler.de/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="entwickler.de &raquo; Force Feedback Programming in Visual Studio Kommentar-Feed" href="https://entwickler.de/online/windowsdeveloper/force-feedback-programming-visual-studio-579766435.html/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/entwickler.de\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://entwickler.de/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='db_twitter_feed-default-css'  href='https://entwickler.de/wp-content/plugins/devbuddy-twitter-feed/assets/feed.css?ver=2.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://entwickler.de/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=4.12' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://entwickler.de/wp-includes/css/dashicons.min.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='gmw-style-css'  href='https://entwickler.de/wp-content/plugins/geo-my-wp/assets/css/style.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='gmw-cl-style-dep-css'  href='https://entwickler.de/wp-content/plugins/geo-my-wp/assets/css/gmw-cl-style-dep.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='sands-top-article-slider-css'  href='https://entwickler.de/wp-content/plugins/sands-top-article-slider/assets/top-article-slider.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='sands_jobspot-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/assets/stylesheets/jobspot.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='sands_jobs_jobalert_styles_bs_min-css'  href='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/css/bootstrap.min.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='sands_jobs_jobalert_styles_bs_theme-css'  href='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/css/bootstrap-theme.min.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='//entwickler.de/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='//entwickler.de/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=2.6.4' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='//entwickler.de/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://entwickler.de/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.1' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://entwickler.de/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wpfront-scroll-top-css'  href='https://entwickler.de/wp-content/plugins/wpfront-scroll-top/css/wpfront-scroll-top.css?ver=1.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://entwickler.de/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://entwickler.de/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-style-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/style.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-fontawesome-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/fonticons/font-awesome.min.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-chosen-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/chosen/chosen.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-responsive-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/responsive.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-scrollpane-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/jquery.jscrollpane.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-magnific-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/magnific-popup.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-carousel-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/owl-carousel/owl.carousel.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-woocommerce-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/woocommerce.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-style-midnightblue-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/css/style-midnightblue.css?ver=beta' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-additional-style-css'  href='https://entwickler.de/wp-content/themes/entwicklerDE/public/jkreativ-icon/jkreativ-icon.min.css?ver=beta' type='text/css' media='all' />
<style id='jeg-additional-style-inline-css' type='text/css'>


/** font setup **/


#navbar, .header-style-1 .logo,
.top-search [name='s'] {
    height: 60px;
}

header ul.menu > li > a, .top-socials li,
.top-search-toggle, .top-search [name='s'] {
    line-height: 60px;
}

.logo img {
    margin-left:    15px;
    margin-top:     5px;
    margin-right:   15px;
    margin-bottom:  0px;
}






/* Side Feed  */

/* Side Feed Active */



    #footer-content { background: #313131 }





#main { background-position: center center; }



    @media only screen and (min-width : 320px) and (max-width : 1024px) {
        .mobile-toggle, #navbar, .header-style-1 .logo, .top-search [name='s'] {
            height: 60px;
            line-height: 60px;
        }
    }



/*** additional css ***/
.header-style-2 .logo {
    margin-top: 27px;
    margin-left: 20px;
}

/* Shop page DFP Banners */
@media only screen and (min-width: 769px){
	.dfp-banner-hide-only-on-desktop{
		display:none;
	}
}

@media only screen and (max-width: 768px){
	.dfp-banner-show-only-on-desktop{
		display:none;
	}
}


/* hack for dotnet summmit speakerbox */
.sq-column, .sq-columns {
	    float: left;
	    position: relative;
	    min-height: 1px;
	}   
	
	.sq-twelve{width:100%;}
	.sq-eleven{width:90%;}
	.sq-ten{width:80%;}
	.sq-nine{width:75%;}
	.sq-eight{width:65%;}
	.sq-seven{width:55%;}
	.sq-six{width:50%;}
	.sq-five{width:65%;}
	.sq-four{width:33%; margin-right: 2%;}
	.sq-three{width:23%; margin-right: 2%;}
	.sq-two{width:17%; margin-right: 3%;}
	.sq-one{width:8%; margin-right: 2%;}
	
	.sq-body{
/*	    width: 100%;
	    max-width:750px;
*/
	    overflow: hidden !important;
 	    background-color: #efefef; 
	    display: block;
	    margin: 0 0 20px 0;
	    padding: 10px 15px 20px 15px;
	    font-family: "Montserrat";
	    font-size: 13px;
	    /*min-width:319px;*/
/*float:left;
width:100%;*/
	}
	
.sands-sq-session-title {
    	background-color: transparent !important;
	}
	
	
.sq-body > li {
		list-style: none;
	}
	
.sq-session-block .conference-info-logo img{
		max-width: 100%;
	}
	
.sq-session-block{
		    border-bottom: dotted 1px #999;
	    margin-top: 10px;
	    padding-bottom: 10px;
    min-height: 105px;
-webkit-box-sizing: border-box;
   -moz-box-sizing: border-box;
        box-sizing: border-box;
	}
	
.sq-session-block	.sq-gdlr-session-thumbnail-wrapper img{
		width: 100%;
		height: auto;
	}
	
.sq-speakers-name-and-company a{
		text-decoration: none;
	    font-size: 13px;
/* 	    color:#08417B; */
	}
	
	.sq-speakers-name-and-company a:hover{
		text-decoration: underline;
	}
	
.sq-session-block .sq-speakers-name-and-company em{
		text-decoration: none;
	    font-size: 12px;
	}
	
.sq-session-block	li .button-link-to-website {
		padding: 10px 0;
		margin-top: 10px;
		display: inline-block;
	}
	
.sq-session-block	li .button-link-to-website a.button{
		text-decoration: none;
/* 		background:#a4c408; */
		padding: 10px;
/* 		color: #fff; */
	    border-radius: 3px;
	    font-size: 14px;
	    font-weight: 700;
	}
	
.sq-session-block	li .button-link-to-website a.button:hover{
		text-decoration: underline;
	}
.sq-session-block .widget.widget_text{
	float:left;
	width:100%;
}
.sands-sq-speakers-infos{
	color:#666;
}
.sq-session-block li .button-link-to-website a.button{
	background:#ffcc00;
	color:#000;
}
.sq-session-block li .button-link-to-website a.button:hover{
	background:#e5ac26;
}
.sands-sq-body-background h3 {margin:0px !important;}
.sands-sq-body-background  .gdlr-speaker-thumbnail {margin:8px 0 0 0 !important;}
.sq-session-title a {
    color: #333 !important;
    text-decoration: none;
    letter-spacing: 0;
		font-size:14px !important; 
		margin: 0 0 5px 0 !important;
}


.sq-session-block {
    border-bottom: dotted 1px #999;
    margin-top: 10px;
    padding-bottom: 10px;
    min-height: 105px;
    -webkit-box-sizing: border-box;
    -moz-box-sizing: border-box;
    box-sizing: border-box;
}

.sq-speakers-name-and-company a {
    text-decoration: none;
    font-size: 13px;
    color: #08417B;
    line-height:13px;
}

.sands-sq-body-background li .button-link-to-website {
    padding: 10px 0;
    margin-top: 10px;
    display: inline-block;
}

.sands-sq-body-background li .button-link-to-website a.button {
    text-decoration: none;
    background: #ffcc00;
    padding: 10px;
    color: #000;
    border-radius: 3px;
    font-size: 14px;
    font-weight: 700;
}

.page-template-magazin-landingpage .mag-issue-detail-orderbutton {border: 0px #f0f0f0 solid;
background: transparent}

.main-nav .home {display:none;}
@media only screen and (min-width: 1201px){
#top-promotion {
    text-align: left;
    margin-bottom: 30px;
    margin-left: 340px;
}
}

/* wbounce */

@media only screen and (max-width: 768px){
.mobile-only {
    display: block !important;
}
}

.referenzen-logo-onadd-job-page {
    border: 1px solid #ccc;
}



.composer-switch {
    display: block !important;
}

</style>
<link rel='stylesheet' id='jeg_font-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,700,400italic,700italic%7CLora:400,400italic' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-fontawesome-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/fontawesome/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-framework-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/framework/bootstrap.css' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-layouts-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/layouts/layouts.css' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-grid-responsive-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-lightbox-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/lightbox/lightbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='pw-pl-mixitup-style-css'  href='https://entwickler.de/wp-content/plugins/grid-list-post-layout/css/mixitup/mixed.css' type='text/css' media='all' />
<link rel='stylesheet' id='bsf-Defaults-css'  href='https://entwickler.de/wp-content/uploads/smile_fonts/Defaults/Defaults.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-twitterbootstrap-css'  href='https://entwickler.de/wp-content/plugins/woocommerce-twitterbootstrap/css/woocommerce-twitterboostrap.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-css'  href='https://entwickler.de/wp-content/plugins/sabai/assets/css/main.min.css?ver=1.3.23' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-font-awesome-css'  href='https://entwickler.de/wp-content/plugins/sabai/assets/css/font-awesome.min.css?ver=1.3.23' type='text/css' media='all' />
<link rel='stylesheet' id='sabai-discuss-css'  href='https://entwickler.de/wp-content/plugins/sabai-discuss/assets/css/main.min.css?ver=1.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?libraries=places&#038;key=AIzaSyA9QVPRKdNm3gpEd2_JmnD4n6U8tW2RFuk&#038;region=DE&#038;language=DE&#038;sansor=false&#038;ver=2.6.4'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/html5-responsive-faq/js/hrf-script.js?ver=4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxjobsubmissionajax = {"ajaxurl":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands_job_processing_form/js/sandsjobprocessing.js?ver=4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxjobalert = {"ajaxurl":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/js/sandsjobsalert.js?ver=4.6'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands_jobs_jobalert/assets/js/bootstrap.min.js?ver=4.6'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/wpfront-scroll-top/js/wpfront-scroll-top.js?ver=1.4.4'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/masonry/masonry.js?ver=4.6'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/lightbox/lightbox-2.6.min.js?ver=4.6'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/mixitup/jquery.mixitup.js?ver=4.6'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/grid-list-post-layout/js/custom.js?ver=4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var afp_vars = {"afp_nonce":"33a1374aa9","afp_ajax_url":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/ajax-filter-posts.js'></script>
<link rel='https://api.w.org/' href='https://entwickler.de/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://entwickler.de/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://entwickler.de/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.6" />
<meta name="generator" content="WooCommerce 2.6.4" />
<link rel='shortlink' href='https://entwickler.de/?p=579766435' />
<link rel="alternate" type="application/json+oembed" href="https://entwickler.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fentwickler.de%2Fonline%2Fwindowsdeveloper%2Fforce-feedback-programming-visual-studio-579766435.html" />
<link rel="alternate" type="text/xml+oembed" href="https://entwickler.de/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fentwickler.de%2Fonline%2Fwindowsdeveloper%2Fforce-feedback-programming-visual-studio-579766435.html&#038;format=xml" />
	<style type="text/css">
		div.wpcf7 .screen-reader-response {
			display: none;
		}
		div.wpcf7 img.ajax-loader {
			border: none;
			vertical-align: middle;
			margin-left: 4px;
		}
		div.wpcf7 .form-inline img.ajax-loader {
			display: inline;
		}
		div.wpcf7 div.ajax-error {
			display: none;
		}
		div.wpcf7 .wpcf7-display-none {
			display: none;
		}
		div.wpcf7 .form-inline .form-group {
			max-width: 250px;
		}
		div.wpcf7 .input-group-addon img {
			height: 100%;
			width: auto;
			max-width: none !important;
			border-radius: 5px;
		}
		div.wpcf7 .input-group-addon.input-group-has-image {
			padding: 0;
		}
	</style>
	<script type="text/javascript" src="https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/functions.js"> </script> <script type="text/javascript" src="https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/jquery-validate.bootstrap-tooltip.min.js"> </script> <script type="text/javascript" src="https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/jquery.validate.min.js"> </script> <link rel="stylesheet" type="text/css" media="all" href="https://entwickler.de/wp-content/themes/entwicklerDE/assets/stylesheets/sands-style.css?ver=1.3" /><link rel="stylesheet" type="text/css" media="all" href="https://entwickler.de/wp-content/themes/entwicklerDE/assets/stylesheets/kiosk-style.css?ver=1.2" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://entwickler.de/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://entwickler.de/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="amphtml" href="https://entwickler.de/online/windowsdeveloper/force-feedback-programming-visual-studio-579766435.html/amp" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><!-- WooCommerce Colors -->
<style type="text/css">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</style>
<!--/WooCommerce Colors-->
    <script type="text/javascript">var templateDirUrl = 'https://entwickler.de/wp-content/themes/entwicklerDE';</script> 
    


<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
<script type="text/javascript">
    window.cookieconsent_options = {"message":"Diese Website verwendet Cookies von Google, um ihre Dienste bereitzustellen, Anzeigen zu personalisieren und Zugriffe zu analysieren. Informationen darüber, wie du die Website verwendest, werden an Google weitergegeben.","dismiss":"Einverstanden","learnMore":"Mehr Infos","link":"https://entwickler.de/datenschutz","theme":"dark-bottom"};
</script>

<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
<!-- End Cookie Consent plugin -->
</head>
<body Windows Developer class="single single-post postid-579766435 single-format-standard jmagz post-force-feedback-programming-visual-studio category-windowsdeveloper wpb-js-composer js-comp-ver-4.12 vc_responsive">
             
       
	           
<nav id="mobile-menu" role="navigation">
    <section class="mobile-menu-container">
        <section class="mobile-search">
            <form method="get" class="search-form" action="https://entwickler.de/">
    <input type="text" autocomplete="off" name="s" placeholder="Suchbegriff eingeben und Enter drücken">
    <button type="submit" name="button"><i data-loading="fa fa-spinner fa-spin" data-normal="fa fa-search" class="fa fa-search"></i></button>
</form>        </section>
				<div class="sand-mobile-cat-block">
		<h3>Themen</h3>		
			<div id="nav_menu-15" class="widget widget_nav_menu"><div class="menu-entwickler-online-cat-sub-navi-container"><ul id="menu-entwickler-online-cat-sub-navi" class="menu"><li id="menu-item-255830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255830"><a href="https://entwickler.de/online/php">PHP</a></li>
<li id="menu-item-255831" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-255831"><a href="https://entwickler.de/online/windowsdeveloper">Windows Developer</a></li>
<li id="menu-item-255832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255832"><a href="https://entwickler.de/online/mobile">Mobile</a></li>
<li id="menu-item-255833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255833"><a href="https://entwickler.de/online/javascript">JavaScript</a></li>
<li id="menu-item-255839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255839"><a href="https://entwickler.de/online/iot">IoT</a></li>
<li id="menu-item-255834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255834"><a href="https://entwickler.de/online/development">Development</a></li>
<li id="menu-item-255843" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255843"><a href="https://entwickler.de/online/agile">Agile</a></li>
<li id="menu-item-261621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261621"><a href="https://entwickler.de/online/tools">Tools</a></li>
<li id="menu-item-255842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255842"><a href="https://entwickler.de/online/ux">UX</a></li>
<li id="menu-item-255836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255836"><a href="https://entwickler.de/online/web">Web</a></li>
<li id="menu-item-255835" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255835"><a href="https://entwickler.de/online/webmagazin">WebMagazin</a></li>
<li id="menu-item-270629" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-270629"><a href="https://entwickler.de/tag/.net">.NET</a></li>
<li id="menu-item-274742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-274742"><a href="https://entwickler.de/tv">entwickler.tv</a></li>
</ul></div></div>		</div>
		<div class="clear"></div>
				
        <ul id="menu-mobile-menu" class=""><li id="menu-item-149197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149197 bgnav"><a href="/kiosk">.kiosk</a></li><li id="menu-item-149199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149199 bgnav"><a href="/events">.events</a></li><li id="menu-item-149201" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149201 bgnav"><a href="https://entwickler.de/magazine">.magazine</a></li><li id="menu-item-149203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149203 bgnav"><a href="/shop">.shop</a></li><li id="menu-item-245524" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-245524 bgnav"><a href="/jobs">.jobs</a></li><li id="menu-item-149204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149204 bgnav"><a href="/press">.press</a></li><li id="menu-item-149206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149206 bgnav"><a href="https://entwickler.de/kontakt">.service</a></li><li id="menu-item-206104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206104 bgnav"><a href="https://entwickler.de/fragen-antworten">.q&#038;a</a></li><li id="menu-item-149207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149207 bgnav"><a href="https://entwickler.de/my-account">Anmelden|Abmelden</a></li><li id="menu-item-149208" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149208 bgnav"><a href="https://entwickler.de/kiosk">Registrieren</a></li></ul>    </section>
</nav><header class="header-style-1">
   
    <div id="navbar">
                <a href="https://entwickler.de" class="logo"><img src="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" data-at2x="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" alt=&#039;Das ganze Spektrum der Softwareentwicklung&#039;></a>
        <a href="https://entwickler.de" class="mobile-logo"><img src="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" data-at2x="https://entwickler.de/wp-content/uploads/2015/05/logo-mobile-ent.png" alt=&#039;Das ganze Spektrum der Softwareentwicklung&#039;></a>
        <nav class="main-nav">
            <ul class="menu">
    <li class="home "><a href="https://entwickler.de"><i class="fa fa-home"></i></a></li>
    <li id="menu-item-149149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-149149 bgnav"><a href="/online">.online</a>
<ul class="childmenu">
	<li id="menu-item-239437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239437 bgnav"><a href="https://entwickler.de/online/php">PHP</a></li>
	<li id="menu-item-239436" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-239436 bgnav"><a href="https://entwickler.de/online/windowsdeveloper">Windows Developer</a></li>
	<li id="menu-item-239440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239440 bgnav"><a href="https://entwickler.de/online/mobile">Mobile</a></li>
	<li id="menu-item-239439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239439 bgnav"><a href="https://entwickler.de/online/javascript">JavaScript</a></li>
	<li id="menu-item-239444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239444 bgnav"><a href="https://entwickler.de/online/iot">IoT</a></li>
	<li id="menu-item-239441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239441 bgnav"><a href="https://entwickler.de/online/development">Development</a></li>
	<li id="menu-item-239445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239445 bgnav"><a href="https://entwickler.de/online/netzkultur">Netzkultur</a></li>
	<li id="menu-item-239447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239447 bgnav"><a href="https://entwickler.de/online/agile">Agile</a></li>
	<li id="menu-item-261651" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261651 bgnav"><a href="https://entwickler.de/online/tools">Tools</a></li>
	<li id="menu-item-239448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239448 bgnav"><a href="https://entwickler.de/online/ux">UX</a></li>
	<li id="menu-item-239438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239438 bgnav"><a href="https://entwickler.de/online/web">Web</a></li>
	<li id="menu-item-239449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239449 bgnav"><a href="https://entwickler.de/online/e-business">E-Business</a></li>
	<li id="menu-item-239435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239435 bgnav"><a href="https://entwickler.de/online/webmagazin">WebMagazin</a></li>
	<li id="menu-item-239453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-239453 bgnav"><a href="https://entwickler.de/online/startups">Startups</a></li>
</ul>
</li>
<li id="menu-item-149155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149155 bgnav"><a href="/kiosk">.kiosk</a></li>
<li id="menu-item-149156" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149156 bgnav"><a href="/events">.events</a></li>
<li id="menu-item-149164" class="entwickler-magazine-add-item menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-149164 bgnav"><a href="https://entwickler.de/magazine">.magazine</a>
<ul class="childmenu">
	<li id="menu-item-170164" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170164 bgnav"><a href="https://entwickler.de/kontakt">Kontakt &#038; Leserservice</a></li>
	<li id="menu-item-149167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149167 bgnav"><a href="https://entwickler.de/entwickler-magazin">Entwickler Magazin</a></li>
	<li id="menu-item-149168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149168 bgnav"><a href="https://entwickler.de/php-magazin">PHP Magazin</a></li>
	<li id="menu-item-164903" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164903 bgnav"><a href="https://entwickler.de/windows-developer-magazin">Windows Developer</a></li>
	<li id="menu-item-149171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149171 bgnav"><a href="https://entwickler.de/mobile-technology">Mobile Technology</a></li>
	<li id="menu-item-294796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294796 bgnav"><a href="https://entwickler.de/javascript-kompendium">JavaScript Kompendium</a></li>
	<li id="menu-item-164905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164905 bgnav"><a href="https://entwickler.de/sharepoint-magazin">SharePoint Kompendium</a></li>
</ul>
</li>
<li id="menu-item-149172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149172 bgnav"><a href="/shop">.shop</a></li>
<li id="menu-item-202600" class="entwickler-job-add-item menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-202600 bgnav"><a href="https://entwickler.de/jobs">.jobs</a>
<ul class="childmenu">
	<li id="menu-item-291611" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-291611 bgnav"><a href="https://entwickler.de/jobs">Alle Jobs</a></li>
	<li id="menu-item-202599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-202599 bgnav"><a href="https://entwickler.de/jobs/add-job">Job hinzufügen</a></li>
	<li id="menu-item-202598" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-202598 bgnav"><a href="https://entwickler.de/job-faq">FAQ</a></li>
</ul>
</li>
<li id="menu-item-149176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-149176 bgnav"><a href="/press">.press</a>
<ul class="childmenu">
	<li id="menu-item-149177" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149177 bgnav"><a href="https://entwickler.de/press/buecher">Bücher &#038; E-Books</a></li>
	<li id="menu-item-149182" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149182 bgnav"><a href="https://entwickler.de/press/shortcuts">Shortcuts</a></li>
	<li id="menu-item-149273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149273 bgnav"><a href="https://entwickler.de/kontakt-service-entwickler-press">Kontakt &#038; Service</a></li>
</ul>
</li>
<li id="menu-item-149186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-149186 bgnav"><a href="https://entwickler.de/kontakt">.service</a>
<ul class="childmenu">
	<li id="menu-item-159169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-159169 bgnav"><a title="Fragen und Antworten" href="https://entwickler.de/fragen-antworten">Q&#038;A</a>
	<ul class="childmenu">
		<li id="menu-item-159171" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-159171 bgnav"><a href="https://entwickler.de/qa/frage-stellen">Eine Frage stellen</a></li>
	</ul>
</li>
	<li id="menu-item-149188" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149188 bgnav"><a href="/kontakt">Leserservice &#038; Kontakt</a></li>
	<li id="menu-item-149189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149189 bgnav"><a href="/autor-werden">Autor werden</a></li>
	<li id="menu-item-152084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152084 bgnav"><a href="https://entwickler.de/digital-lesen">Digital lesen</a></li>
	<li id="menu-item-149190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149190 bgnav"><a href="/anzeigenservice">Werbung</a></li>
	<li id="menu-item-149192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149192 bgnav"><a href="https://entwickler.de/social-media-uebersicht">Social Media</a></li>
	<li id="menu-item-149274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149274 bgnav"><a href="https://entwickler.de/redaktion">Die Redaktion</a></li>
</ul>
</li>
</ul>            <div class="right-nav">

        <ul class="right-menu menu">
        <li>
            <a href="#"><i class="fa fa-user"></i></a>
                        <ul>
                <li class="toplogin">
                    <a href="https://entwickler.de/my-account">Anmelden &amp; Registrieren</a>
                </li>
            </ul>
                    </li>
        <li><a href="#"><i class="fa fa-shopping-cart"></i></a>
            <ul class="topcart"></ul>
        </li>
    </ul>
    
            <ul class="top-socials">
            <li><a target='_blank' href='https://entwickler.de/feed/rss2'><i class='fa fa-rss'></i></a></li>        </ul><!-- /.top-socials -->
                <div class="top-search no-active">
            <a href="#" class="top-search-toggle"><i class="fa fa-search"></i></a>
            <form method="get" class="search-form" action="https://entwickler.de/">
    <input type="text" autocomplete="off" name="s" placeholder="Suchbegriff eingeben und Enter drücken">
    <button type="submit" name="button"><i data-loading="fa fa-spinner fa-spin" data-normal="fa fa-search" class="fa fa-search"></i></button>
</form>            <div class="search-result">
                <div class="search-result-wrapper">

                </div>
                <div class="search-noresult">
                    Kein Ergebnis                </div>
                <div class="search-all-button">
                    Alle Ergebnisse                </div>
            </div>
        </div>
    </div><!-- /.right-nav -->        </nav>
        <a href="#" class="mobile-toggle menu-toggle"><i class="fa fa-navicon"></i></a>
    
  			<style>
			@media only screen and (min-width: 1200px){
				.header-style-1 {height: 100px;}
			}
			</style>
			<div class="col-xs-12 online-sub-navbar-block visible-lg">
			<div id="nav_menu-15" class="widget widget_nav_menu"><div class="menu-entwickler-online-cat-sub-navi-container"><ul id="menu-entwickler-online-cat-sub-navi-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255830"><a href="https://entwickler.de/online/php">PHP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-255831"><a href="https://entwickler.de/online/windowsdeveloper">Windows Developer</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255832"><a href="https://entwickler.de/online/mobile">Mobile</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255833"><a href="https://entwickler.de/online/javascript">JavaScript</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255839"><a href="https://entwickler.de/online/iot">IoT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255834"><a href="https://entwickler.de/online/development">Development</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255843"><a href="https://entwickler.de/online/agile">Agile</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-261621"><a href="https://entwickler.de/online/tools">Tools</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255842"><a href="https://entwickler.de/online/ux">UX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255836"><a href="https://entwickler.de/online/web">Web</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255835"><a href="https://entwickler.de/online/webmagazin">WebMagazin</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-270629"><a href="https://entwickler.de/tag/.net">.NET</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-274742"><a href="https://entwickler.de/tv">entwickler.tv</a></li>
</ul></div></div>			</div>
	
			 </div> </header><aside id="sidebar">
    <section class="sands-sidebar-posts"> 
        <div class="sidebar-post-wrapper">
            <h2 class="sidebar-heading">Aktuelle Beiträge</h2>
            <div class='active sidebar-post-item clearfix ' data-id='579766435'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/windowsdeveloper/force-feedback-programming-visual-studio-579766435.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/01/shutterstock_165738023-90x45.jpg' alt='Force Feedback Programming in Visual Studio'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/windowsdeveloper/force-feedback-programming-visual-studio-579766435.html'>Force Feedback Programming in Visual Studio</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/windowsdeveloper' rel='category'>Windows Developer</a></span><br /><time class='' datetime='2017-01-24 11:55:34'>seit 2 Minuten online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix post-video' data-id='579766597'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/iot/iot-status-quo-579766597.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/01/iotcon-conrad-wood-90x45.jpg' alt='IoT Status Quo – von gestern und von heute'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/iot/iot-status-quo-579766597.html'>IoT Status Quo – von gestern und von heute</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/iot' rel='category'>IoT</a></span><br /><time class='' datetime='2017-01-24 11:02:41'>seit 55 Minuten online</time>
                        </footer>
                    </div>
                </div><div class='sidebar-post-item sidebar-promotion clearfix'><!-- entwickler.de_contentAD1_Wordpress -->

<div id='div-gpt-ad-1423481258370-0'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-0'); });
</script>
</div>


<!-- <h2 class="sidebar-heading">Top Jobs</h2>
<div style="margin:0 0 0 14px">
<h2 style="font-weight:700; margin-bottom:15px; font-size:17px"><a style="color:#000;" href="https://entwickler.de/wp-content/uploads/2016/01/Software-ArchitektmwfürMaterialfluss-und-Intralogistikprojekte.pdf">Software-Architekt (m/w)</a></h2>
<a style="color:#000;" href="https://entwickler.de/wp-content/uploads/2016/01/Software-ArchitektmwfürMaterialfluss-und-Intralogistikprojekte.pdf"><img style="margin-bottom:10px;" src="https://entwickler.de/wp-content/uploads/2016/01/vanderlande.jpg" alt="VANDERLANDE" title="VANDERLANDE"  width="150"/></a>
</div>--></div><div class=' sidebar-post-item clearfix ' data-id='579766605'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/development/updates-emberjs-ember-data-cakephp-2-9-5-579766605.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/01/ff-ember-updates-cakephp-90x45.jpg' alt='Fast Forward: Updates für Ember.js und Ember Data &#038; CakePHP 2.9.5 ist da'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/development/updates-emberjs-ember-data-cakephp-2-9-5-579766605.html'>Fast Forward: Updates für Ember.js und Ember Data &#038; CakePHP 2.9.5 ist da</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/development' rel='category'>Development</a></span><br /><time class='' datetime='2017-01-24 10:21:43'>seit 2 Stunden online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix ' data-id='579748902'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/windowsdeveloper/dotnet-framework-abgebrochene-datenverbindung-579748902.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2016/11/Untitled222-90x45.jpg' alt='.NET Framework: Abgebrochene Datenverbindungen automatisch wieder aufbauen'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/windowsdeveloper/dotnet-framework-abgebrochene-datenverbindung-579748902.html'>.NET Framework: Abgebrochene Datenverbindungen automatisch wieder aufbauen</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/windowsdeveloper' rel='category'>Windows Developer</a></span><br /><time class='' datetime='2017-01-24 09:20:51'>seit 3 Stunden online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix ' data-id='579766439'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/development/cakephp-3-4-0-rc3-seo-angular-stateful-components-579766439.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/01/ff-cakephp-seo-angular-90x45.jpg' alt='Fast Forward: CakePHP 3.4.0-RC3, SEO in Angular &#038; Stateful Components verbinden'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/development/cakephp-3-4-0-rc3-seo-angular-stateful-components-579766439.html'>Fast Forward: CakePHP 3.4.0-RC3, SEO in Angular &#038; Stateful Components verbinden</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/development' rel='category'>Development</a></span><br /><time class='' datetime='2017-01-23 15:55:21'>seit 20 Stunden online</time>
                        </footer>
                    </div>
                </div><div class=' sidebar-post-item clearfix ' data-id='579766433'>
                    <figure class="thumb  ">
                <a href="https://entwickler.de/online/development/gitlab-8-16-579766433.html" class="ajax">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/75x75.png' data-src='https://entwickler.de/wp-content/uploads/2017/01/lab-90x45.jpg' alt='GitLab 8.16 ist erschienen'>
                </a>
            </figure>
                    <div class='content'>
                        <h3 class='post-title'><a class='ajax' href='https://entwickler.de/online/development/gitlab-8-16-579766433.html'>GitLab 8.16 ist erschienen</a></h3>
                        <footer class='post-meta'>
                            <span class='post-category'><a href='https://entwickler.de/online/development' rel='category'>Development</a></span><br /><time class='' datetime='2017-01-23 15:14:31'>seit 21 Stunden online</time>
                        </footer>
                    </div>
                </div>        </div>
				
					<div class="sidebar-post-item clearfix sidebar-custom-ad-block">
			 
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-16" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<!-- entwickler.de_contentAD2_Wordpress -->
<div id='div-gpt-ad-1423481258370-1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-1'); });
</script>
</div>
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
			</div>
				<div class="sidebar-post-item clearfix sidebaradditional">
		 <div id="text-23" class="widget widget_text">			<div class="textwidget"><strong>Weitere Themenkategorien:</strong></div>
		</div><div id="nav_menu-13" class="widget widget_nav_menu"><div class="menu-entwickler-online-container"><ul id="menu-entwickler-online" class="menu"><li id="menu-item-163505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163505"><a href="https://entwickler.de/online/tools">• Tools</a></li>
<li id="menu-item-171666" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171666"><a href="https://entwickler.de/online/security">• Security</a></li>
<li id="menu-item-164602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-164602"><a title="Alles rund um Docker" href="https://entwickler.de/tag/docker">• Docker</a></li>
<li id="menu-item-112703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112703"><a href="https://entwickler.de/online/datenbanken">• Datenbanken</a></li>
<li id="menu-item-168331" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-168331"><a href="https://entwickler.de/online/cloud">• Cloud</a></li>
<li id="menu-item-168884" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-168884"><a href="https://entwickler.de/windows-10-special">• Windows-10-Special</a></li>
</ul></div></div><div id="text-22" class="widget widget_text">			<div class="textwidget"><p>&nbsp;</p></div>
		</div>		</div>
    </section>

    <div class="sidebar-footer">
        <footer class="bottom">
            <p class="copyright"></p>
        </footer>
    </div>
</aside>
<div id="main">

<div class="section-wrap">
    <div class="wrapper">
            <div id="top-promotion">
        <div class="dfp-banner-show-only-on-desktop">
<!-- entwickler.de_leaderboard_Wordpress -->
            <div id='div-gpt-ad-1423481258370-5' style='width:100%; height:90px; margin-left: 30px;'>
            <script type='text/javascript'>
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-5'); });
            </script>
            </div>
</div>
    </div>
    


<div id="content" class="container">
    <article class="clearfix post-579766435 post type-post status-publish format-standard has-post-thumbnail hentry category-windowsdeveloper tag-basta tag-clean-code tag-force-feedback tag-visual-studio" itemscope itemtype="http://schema.org/article">
        <header class="post-header clearfix">
        <div class="post-top-meta clearfix">
        <div class="breadcrumb" prefix="v: http://rdf.data-vocabulary.org/#"><span class="breadcrumb-item home-breadcrumb" typeof="v:Breadcrumb"><a href='https://entwickler.de' rel="v:url" property="v:title">Start</a></span><span class="breadcrumb-item" typeof="v:Breadcrumb"><a href='https://entwickler.de/online' rel="v:url" property="v:title"> Online</a></span><span class="breadcrumb-item" typeof="v:Breadcrumb"><a href='https://entwickler.de/online/windowsdeveloper' rel="v:url" property="v:title"> Windows Developer</a></span></div>        <div class="post-date">
            <time class="post-date" itemprop="dateCreated" datetime="2017-01-24 11:55:34">Dienstag, 24. Januar 2017</time>
            <meta itemprop="datePublished" content="2017-01-24 11:55:34">
        </div>
		    </div>
        <div class="post-header-container">
		
	<span><center><iframe class="desktop-only" style="margin: 0 0 15px 0; padding: 0px; overflow: hidden; border: none;" src="https://basta.net/session-qualification/wp-sidebar-feed-featured-box-basta-se/?layout=contentareafeed" width="785" height="385" scrolling="no"></iframe></center></span>
	               <h1 class="tagline h1-looks-like-tagline" itemprop="headline">Direktes Feedback für besseren Code durch Visual Studio Erweiterung</h1>
        	
        <div class="post-title h1-post-title" itemprop="name">Force Feedback Programming in Visual Studio</div>
                    <div class="post-bottom-meta">
                				<span class="post-author"><a itemprop="author" href="https://entwickler.de/author/robinsedlaczek">Robin Sedlaczek</a> </span>                <time class="post-date" itemprop="dateCreated" datetime="2017-01-24 11:55:34">2 Minuten online</time>
                <span class="post-total-comment"><a href="#comments">Kommentare</a></span>            </div>
                
                    <div class="excerpt">
                <p>Feedback ist wichtig, Feedback definiert unser Leben. Ohne Feedback würden wir Menschen nicht wissen, ob wir etwas richtig machen oder nicht. Sauberer Code ist ebenfalls wichtig, im Sinne der Wartbarkeit und Erweiterbarkeit. Die Clean Code-Initiative forciert genau das. Warum also nicht beides zusammenführen? Force Feedback Programming versucht, genau diesen Weg zu gehen. </p>
            </div>
            </div>
</header>

            <div class="col-sm-8 col-md-8">
            <figure class='featured featured-image'>
                        <img itemprop='image' src='https://entwickler.de/wp-content/uploads/2017/01/shutterstock_165738023-900x450.jpg' alt='Force Feedback Programming in Visual Studio'>
                        <p class='wp-caption-text'><p class="SuSLinksundLiteraturText">© shutterstock.com / STILLFX</p></p>
                    </figure>            </div>


            <div class="social-icons hidden-xs col-md-1"><section class="sands-article-sharer section">
    <div class="socials-share">
        <a target="_blank" data-shareto="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://entwickler.de/?p=579766435" class="social-share share-facebook">
            <i class="fa fa-facebook"></i>
        </a>
        <a target="_blank" data-shareto="Twitter" href="https://twitter.com/home?status=Ich+empfehle+diesen+Artikel%3A+https%3A%2F%2Fentwickler.de%2F%3Fp%3D579766435" class="social-share share-twitter">
            <i class="fa fa-twitter"></i>
        </a>
        <a target="_blank" data-shareto="Google" href="https://plus.google.com/share?url=https://entwickler.de/?p=579766435" class="social-share share-google-plus">
            <i class="fa fa-google-plus"></i>
        </a>
        <a target="_blank" data-shareto="XING" href="https://www.xing.com/spi/shares/new?url=https://entwickler.de/?p=579766435&amp;title=http%3A%2F%2FForce%2520Feedback%2520Programming%2520in%2520Visual%2520Studio&amp;description=Feedback+ist+wichtig%2C+Feedback+definiert+unser+Leben.+Ohne+Feedback+w%C3%BCrden+wir+Menschen+nicht+wissen%2C+ob+wir+etwas+richtig+machen+oder+nicht.+Sauberer+Code+ist+ebenfalls+wichtig%2C+im+Sinne+der+Wartbarkeit+und+Erweiterbarkeit.+Die+Clean+Code-Initiative+forciert+genau+das.+Warum+also+nicht+beides+zusammenf%C3%BChren%3F+Force+Feedback+Programming+versucht%2C+genau+diesen+Weg+zu+gehen.&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-xing">
            <i class="fa fa-xing"></i>
        </a>
        <a target="_blank" data-shareto="Linked In" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://entwickler.de/?p=579766435&amp;title=http%3A%2F%2FForce%2520Feedback%2520Programming%2520in%2520Visual%2520Studio&amp;summary=Feedback+ist+wichtig%2C+Feedback+definiert+unser+Leben.+Ohne+Feedback+w%C3%BCrden+wir+Menschen+nicht+wissen%2C+ob+wir+etwas+richtig+machen+oder+nicht.+Sauberer+Code+ist+ebenfalls+wichtig%2C+im+Sinne+der+Wartbarkeit+und+Erweiterbarkeit.+Die+Clean+Code-Initiative+forciert+genau+das.+Warum+also+nicht+beides+zusammenf%C3%BChren%3F+Force+Feedback+Programming+versucht%2C+genau+diesen+Weg+zu+gehen.&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-linkedin">
            <i class="fa fa-linkedin"></i>
        </a>
    </div>
    <!--<div class="article-shorturl">
        <input type="text" id="shorturl" class="shorturl" data-clipboard-text="https://entwickler.de/?p=579766435" value="https://entwickler.de/?p=579766435">
    </div>-->
</section>
<div class="dummy-share-block"></div></div>
            <div class="clearfix"></div>

            <section class="article-content">

                <aside class="aside-post hidden-xs">
                <div class='yarpp-related'>
<h6 class="aside-heading">Mehr zum Thema</h6>
<div class="row yarpp-sands">
<div class='yarpp-sands-item'><a href='https://entwickler.de/online/windowsdeveloper/xaml-tipp-ui-debugging-tools-deaktivieren-299300.html' title='XAML-Tipp: WPF &#8211; UI-Debugging-Tools deaktivieren'>
<div class='col-xs-12 yarpp-sands-image'><img width="230" height="115" src="https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-230x115.jpg" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="shutterstock_471136937" srcset="https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-230x115.jpg 230w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-120x60.jpg 120w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-768x384.jpg 768w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-150x75.jpg 150w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-90x45.jpg 90w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-200x100.jpg 200w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-220x110.jpg 220w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-300x150.jpg 300w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-600x300.jpg 600w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937.jpg 900w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-350x175.jpg 350w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-110x55.jpg 110w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-72x36.jpg 72w, https://entwickler.de/wp-content/uploads/2016/10/shutterstock_471136937-400x200.jpg 400w" sizes="(max-width: 230px) 100vw, 230px" /></div>
<div class="col-xs-12 yarpp-sands-headline"><div class="yarpp-sands-thumbnail-title">XAML-Tipp: WPF &#8211; UI-Debugging-Tools deaktivieren</div></div></a>
</div>
</div>
<div class='clear'></div>
</div>
            </aside>
    	<p class="SuSMengentext">In Zusammenarbeit mit Robin Sedlaczek entstand nach einer Idee von Ralf Westphal eine Open Source Erweiterung für Visual Studio, die anhand bestimmter Metriken versucht, dem Entwickler direktes Feedback zu seinem Code zu geben. Ja, sogar verhindert, schlechten Code zu schreiben. Robin Sedlaczek stellt die Erweiterung ausführlich <a href="https://robinsedlaczek.com/2016/06/23/introducing-force-feedback-programming/" target="_blank">online</a> vor. Ein kurzes Einleitungsvideo gibt es auf <a href="https://vimeo.com/171889390" target="_blank">Vimeo</a>.</p>
<h2 class="SuSMengentext">Markierung langer Methoden in Visual Studio</h2>
<p class="SuSMengentext">Die Erweiterung bedient sich zuerst der Anzahl der Codezeilen pro Methode. Zu lange Methoden werden farblich in der IDE markiert. Je länger die Methode, umso kritischer die farbliche Darstellung des Codes. Das Ganze ist natürlich über eine Konfigurationsdatei einstellbar, denn verschiedene Projekte haben unterschiedliche Anforderungen an die Metrik. <strong>Abbildung 1</strong> zeigt die Erweiterung für Visual Studio in Aktion. Aber nicht nur visuelles Feedback wird gegeben. Die Erweiterung versucht, den Entwickler ebenfalls vom Schreiben schlechten Codes abzuhalten. Dazu gibt sie <a href="http://ralfw.de/2016/06/force-feedback-programming-clean-code-leicht-gemacht/" target="_blank">taktiles Feedback</a>. In Abbildung 1 ist in der Zeile zwischen den grauen Markierungen zu sehen, wie dieses Feedback aussieht.<strong> </strong> Es soll einfach keinen Spaß mehr machen, unsauber zu programmieren.</p>
<div id="attachment_579766450" style="width: 610px" class="wp-caption alignnone"><a href="https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02.png"><img class="wp-image-579766450" src="https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02.png" alt="Abbildung 1: Force Feedback Programming in Aktion mit taktilem Feedback" width="600" height="392" srcset="https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02.png 757w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-120x78.png 120w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-150x98.png 150w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-90x59.png 90w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-200x131.png 200w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-220x144.png 220w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-300x196.png 300w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-600x392.png 600w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-350x228.png 350w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-110x72.png 110w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-72x47.png 72w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-306x200.png 306w, https://entwickler.de/wp-content/uploads/2017/01/ForceFeedback02-230x150.png 230w" sizes="(max-width: 600px) 100vw, 600px" /></a><p class="wp-caption-text">Abbildung 1: Force Feedback Programming in Aktion mit taktilem Feedback</p></div>
<p>Die Erweiterung für Visual Studio ist <a href="https://marketplace.visualstudio.com/items?itemName=RobinSedlaczek.ForceFeedback" target="_blank">über die Visual Studio Gallerie verfügbar</a> und kann darüber direkt im Visual Studio installiert werden. Das Projekt wird als Open-Source-Projekt auf <a href="https://github.com/robinsedlaczek/ForceFeedbackProgramming" target="_blank">GitHub entwickelt</a>. Mitmachen ist erwünscht, und so sucht das Projekt nach interessierten Entwicklern, die die Erweiterung voranbringen möchten. Entwicklungsprozess, Coding Conventions und Contributor Guidelines sind im Wiki des Projektes auf GitHub dokumentiert. Es existiert ebenfalls ein automatisierter Continuous Integration Prozess mit AppVeyor.</p>
<p>Anfänglich gedacht für Trainingszwecke, wird Force Feedback Programming zunehmend auch im produktiven Umfeld eingesetzt. Ausprobieren lohnt sich also! Das Team rund um FFP freut sich über jegliche Art von Feedback! Als Issue auf GitHub oder per direktem Kontakt im <a href="https://gitter.im/robinsedlaczek/ForceFeedbackProgramming" target="_blank">Gitter Chat</a>. Sie können den Autor aber auch direkt auf der <a href="https://basta.net/">BASTA! Spring 2017</a> treffen.</p>

            <div class="visible-xs col-xs-12"><section class="sands-article-sharer section">
    <div class="socials-share">
        <a target="_blank" data-shareto="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://entwickler.de/?p=579766435" class="social-share share-facebook">
            <i class="fa fa-facebook"></i>
        </a>
        <a target="_blank" data-shareto="Twitter" href="https://twitter.com/home?status=Ich+empfehle+diesen+Artikel%3A+https%3A%2F%2Fentwickler.de%2F%3Fp%3D579766435" class="social-share share-twitter">
            <i class="fa fa-twitter"></i>
        </a>
        <a target="_blank" data-shareto="Google" href="https://plus.google.com/share?url=https://entwickler.de/?p=579766435" class="social-share share-google-plus">
            <i class="fa fa-google-plus"></i>
        </a>
        <a target="_blank" data-shareto="XING" href="https://www.xing.com/spi/shares/new?url=https://entwickler.de/?p=579766435&amp;title=http%3A%2F%2FForce%2520Feedback%2520Programming%2520in%2520Visual%2520Studio&amp;description=Feedback+ist+wichtig%2C+Feedback+definiert+unser+Leben.+Ohne+Feedback+w%C3%BCrden+wir+Menschen+nicht+wissen%2C+ob+wir+etwas+richtig+machen+oder+nicht.+Sauberer+Code+ist+ebenfalls+wichtig%2C+im+Sinne+der+Wartbarkeit+und+Erweiterbarkeit.+Die+Clean+Code-Initiative+forciert+genau+das.+Warum+also+nicht+beides+zusammenf%C3%BChren%3F+Force+Feedback+Programming+versucht%2C+genau+diesen+Weg+zu+gehen.&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-xing">
            <i class="fa fa-xing"></i>
        </a>
        <a target="_blank" data-shareto="Linked In" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://entwickler.de/?p=579766435&amp;title=http%3A%2F%2FForce%2520Feedback%2520Programming%2520in%2520Visual%2520Studio&amp;summary=Feedback+ist+wichtig%2C+Feedback+definiert+unser+Leben.+Ohne+Feedback+w%C3%BCrden+wir+Menschen+nicht+wissen%2C+ob+wir+etwas+richtig+machen+oder+nicht.+Sauberer+Code+ist+ebenfalls+wichtig%2C+im+Sinne+der+Wartbarkeit+und+Erweiterbarkeit.+Die+Clean+Code-Initiative+forciert+genau+das.+Warum+also+nicht+beides+zusammenf%C3%BChren%3F+Force+Feedback+Programming+versucht%2C+genau+diesen+Weg+zu+gehen.&amp;source=http%3A%2F%2Fentwickler.de" class="social-share share-linkedin">
            <i class="fa fa-linkedin"></i>
        </a>
    </div>
    <!--<div class="article-shorturl">
        <input type="text" id="shorturl" class="shorturl" data-clipboard-text="https://entwickler.de/?p=579766435" value="https://entwickler.de/?p=579766435">
    </div>-->
</section>
<div class="dummy-share-block"></div></div>
    
            <div class="clearfix"></div>
        <div class="article-tags">
            <a href="https://entwickler.de/tag/basta" rel="tag">basta!</a><a href="https://entwickler.de/tag/clean-code" rel="tag">clean code</a><a href="https://entwickler.de/tag/force-feedback" rel="tag">force feedback</a><a href="https://entwickler.de/tag/visual-studio" rel="tag">visual studio</a>        </div>
        <div id="end-content"></div>

</section>

<section class="popup-post">
    <strong class="popup-heading">Unsere Redaktion empfiehlt:</strong>
    <div class="popup-content">
                <figure class="thumb">
            <a href="https://entwickler.de/online/windowsdeveloper/dotnet-framework-abgebrochene-datenverbindung-579748902.html"><img src="https://entwickler.de/wp-content/uploads/2016/11/Untitled222-90x45.jpg" alt=""></a>
        </figure>
                <h3 class="post-title"><a href="https://entwickler.de/online/windowsdeveloper/dotnet-framework-abgebrochene-datenverbindung-579748902.html">.NET Framework: Abgebrochene Datenverbindungen automatisch wieder aufbauen</a></h3>
    </div>
    <a href="#" class="popup-close"><i class="fa fa-close"></i></a>
</section>


<section id="related-post" class="post-three-columns post-columns section">
    <div class="row clearfix">

        <div class="col-md-12 section-heading-wrapper">
            <h3 class="section-heading">Relevante <strong>Beiträge</strong></h3>
        </div>
    </div>

        <div class="row clearfix relatedfix">
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/windowsdeveloper/dotnet-framework-abgebrochene-datenverbindung-579748902.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2016/11/Untitled222-300x150.jpg' alt='.NET Framework: Abgebrochene Datenverbindungen automatisch wieder aufbauen'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/windowsdeveloper/dotnet-framework-abgebrochene-datenverbindung-579748902.html">.NET Framework: Abgebrochene Datenverbindungen automatisch wieder aufbauen</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/manfredsteyer" rel="author">Manfred Steyer</a>
                        </span>
                        <time class="post-date" datetime="2017-01-24 09:20:51">
                            3 Stunden online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/windowsdeveloper/microsoft-vstest-open-source-579766408.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/01/shutterstock_559735990-300x150.jpg' alt='Microsoft stellt VSTest Open Source'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/windowsdeveloper/microsoft-vstest-open-source-579766408.html">Microsoft stellt VSTest Open Source</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/mascha-schnellbacher" rel="author">Mascha Schnellbacher</a>
                        </span>
                        <time class="post-date" datetime="2017-01-23 14:25:14">
                            22 Stunden online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/windowsdeveloper/windows-10-insider-preview-build-15014-579765786.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2017/01/shutterstock_559562923-300x150.jpg' alt='Windows 10 Insider Preview Build 15014 für Mobile und PC erschienen'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/windowsdeveloper/windows-10-insider-preview-build-15014-579765786.html">Windows 10 Insider Preview Build 15014 für Mobile und PC erschienen</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/mascha-schnellbacher" rel="author">Mascha Schnellbacher</a>
                        </span>
                        <time class="post-date" datetime="2017-01-20 10:55:13">
                            4 Tagen online                        </time>
                    </div>
                </header>
            </article>
        </div>
        </div> <!-- related fix --><div class="row clearfix relatedfix">
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/windowsdeveloper/xaml-tipp-windows-10-apps-passwordrevealmode-300504.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2016/10/Untitled2222-300x150.jpg' alt='XAML-Tipp: Windows-10-Apps – Passwort anzeigen lassen mit dem PasswordRevealMode'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/windowsdeveloper/xaml-tipp-windows-10-apps-passwordrevealmode-300504.html">XAML-Tipp: Windows-10-Apps – Passwort anzeigen lassen mit dem PasswordRevealMode</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/gregorbiswanger" rel="author">Gregor Biswanger</a>
                        </span>
                        <time class="post-date" datetime="2017-01-20 08:41:01">
                            4 Tagen online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/windowsdeveloper/basta-spring-2017-donnerstag-anmelden-sparen-302637.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2016/11/160920-092838-basta2016-130-1500px-300x150.jpg' alt='BASTA! Spring 2017 – Noch bis heute anmelden und sparen'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/windowsdeveloper/basta-spring-2017-donnerstag-anmelden-sparen-302637.html">BASTA! Spring 2017 – Noch bis heute anmelden und sparen</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/mascha-schnellbacher" rel="author">Mascha Schnellbacher</a>
                        </span>
                        <time class="post-date" datetime="2017-01-19 10:10:32">
                            5 Tagen online                        </time>
                    </div>
                </header>
            </article>
        </div>
        
        <div class="col-md-4">
            <article class="post-list">
                <figure class="thumb half-thumb ">
                <a href="https://entwickler.de/online/windowsdeveloper/alle-fehler-getestet-299336.html" class="">
                    <img class='lazyOwl unveil' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/placeholder/450x225.png' data-src='https://entwickler.de/wp-content/uploads/2016/10/Windows-Developer-8-16_Aufmacher_Sturm_istock_P2007_SuS_900x450-300x150.jpg' alt='Alle Fehler getestet?'>
                </a>
            </figure>                <header class="content">
                    <h1 class="post-title"><a href="https://entwickler.de/online/windowsdeveloper/alle-fehler-getestet-299336.html">Alle Fehler getestet?</a></h1>
                    <div class="post-meta">
                        <span class="post-author">Von                            <a href="https://entwickler.de/author/oliversturm" rel="author">Oliver Sturm</a>
                        </span>
                        <time class="post-date" datetime="2017-01-17 11:56:13">
                            1 Woche online                        </time>
                    </div>
                </header>
            </article>
        </div>
        </div> <!-- related fix -->
</section>


        <section id="comments" class="comment-wrapper section"><h3 class='comment-heading'>Meinungen zu diesem Beitrag</h3>            <div id="disqus_thread"></div>
        </section>    </article>
    <!-- Side Ads -->

  


<div id="sidecontent-promotion" class="container">
        <!-- entwickler.de_skyscraper1_Wordpress -->
                <div id='div-gpt-ad-1423481258370-6' class='skyad-right' style="margin-top: 21px;">
                <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1423481258370-6'); });
                </script>
                </div>
</div>


</div>

                    <!-- FOOTER -->
<footer id="footer">
    <div id="footer-content" class="container clearfix">
                        <aside class="col-md-3 column"> <div class="footer-widget widget_nav_menu" id="nav_menu-9"><h2 class="widget-title">Online</h2><div class="menu-online-container"><ul id="menu-online" class="menu"><li id="menu-item-112715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112715"><a href="http://jaxenter.de">JAXenter.de</a></li>
<li id="menu-item-112716" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112716"><a href="http://jaxenter.com">JAXenter.com</a></li>
</ul></div></div> </aside>
                <aside class="col-md-3 column"> <div class="footer-widget widget_nav_menu" id="nav_menu-10"><h2 class="widget-title">Magazine</h2><div class="menu-magazine-container"><ul id="menu-magazine" class="menu"><li id="menu-item-112718" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112718"><a href="http://entwickler.de/php-magazin">PHP Magazin</a></li>
<li id="menu-item-112722" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112722"><a href="http://windowsdeveloper.de/shop">Windows Developer</a></li>
<li id="menu-item-149283" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149283"><a href="http://entwickler.de/entwickler-magazin">Entwickler Magazin</a></li>
<li id="menu-item-149282" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-149282"><a href="http://entwickler.de/mobile-technology">Mobile Technology</a></li>
<li id="menu-item-112723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112723"><a href="http://windowsdeveloper.de/shop">SharePoint Kompendium</a></li>
<li id="menu-item-112719" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112719"><a href="https://jaxenter.de/magazine/java-magazin">Java Magazin</a></li>
<li id="menu-item-112720" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112720"><a href="https://jaxenter.de/magazine/eclipse-magazin">Eclipse Magazin</a></li>
<li id="menu-item-112721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112721"><a href="https://jaxenter.de/magazine/business-technology">Business Technology</a></li>
</ul></div></div> </aside>
                <aside class="col-md-3 column"> <div class="footer-widget widget_nav_menu" id="nav_menu-11"><h2 class="widget-title">Konferenzen</h2><div class="menu-konferenzen-container"><ul id="menu-konferenzen" class="menu"><li id="menu-item-112724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112724"><a href="https://jax.de">JAX</a></li>
<li id="menu-item-112725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112725"><a href="https://basta.net">BASTA!</a></li>
<li id="menu-item-112726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112726"><a href="https://phpconference.com">International PHP Conference</a></li>
<li id="menu-item-112727" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112727"><a href="https://webtechcon.de">WebTech Conference</a></li>
<li id="menu-item-112728" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112728"><a href="https://webinale.de">webinale</a></li>
<li id="menu-item-112729" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112729"><a href="https://mobiletechcon.de/">MobileTech Conference</a></li>
<li id="menu-item-173190" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-173190"><a href="https://iotcon.de/">Internet of Things Conference</a></li>
<li id="menu-item-173189" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-173189"><a href="http://devopsconference.de/de/">DevOpsCon</a></li>
</ul></div></div> </aside>
                <aside class="col-md-3 column"> <div class="footer-widget">
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-15" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<p class="widget-title">S&S Media</p>
<div class="menu-konferenzen-container">
	<ul id="menu-konferenzen-4" class="menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113724"><a href="http://sandsmedia.com/de/unternehmen">Über S&amp;S Media</a></li>
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113725"><a href="http://entwickler-akademie.de/">Entwickler Akademie</a></li>
	</ul>
</div>
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
 </div></aside>
            <aside class="col-md-12 column"> 
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-14" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<ul id="menu-footer-impressum" class="menu"><li id="menu-item-112731" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-112731"><a href="http://sandsmedia.com/">Software &amp; Support Media GmbH</a></li>
<li id="menu-item-112732" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112732"><a href="/impressum">Impressum</a></li>
<li id="menu-item-112733" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112733"><a href="/datenschutz">Datenschutz</a></li>
<li id="menu-item-123344" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-123344"><a href="/entwicklerde_agb">AGB</a></li>
<li id="menu-item-112842" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112842"><a href="/lieferkonditionen">Lieferkonditionen</a></li>
</ul>
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
</aside>
    </div>
    <!-- /.footer-wrapper -->

    <div class="footer-bottom container center" >
	
                <p class="copyright"></p>
    </div>
    <!-- /.footer-bottom -->
</footer>
<!-- /#footer -->                    </div>
                    <div class="ajax-overlay">
                        <div id="postloader"></div>
                    </div>
                </div>
            </div>
                <div id="gmw-cl-form-wrapper" class="gmw-cl-form-wrapper"><span id="gmw-cl-close-btn">X</span><form id="gmw-cl-form" name="gmw_cl_form" onsubmit="return false"><div id="gmw-cl-info-wrapper"><div id="gmw-cl-location-message">- Gib Deinen Standort ein -</div><div id="gmw-cl-input-fields"><input type="text" name="gmw-cl_address" id="gmw-cl-address" value="" placeholder="zipcode or full address..." /><input id="gmw-cl-submit-address" type="submit" value="go" /></div><div> - or - </div><div id="gmw-cl-get-location"><a href="#" id="gmw-cl-trigger" >Erhalte Deinen aktuellen Standort</a></div></div><div id="gmw-cl-respond-wrapper" style="display:none;"><div id="gmw-cl-spinner"><img src="https://entwickler.de/wp-content/plugins/geo-my-wp/assets/images/gmw-loader.gif" /></div><div id="gmw-cl-message"></div><div id="gmw-cl-map" style="width:100%;height:100px;display:none;"></div></div></form></div><div id="gmw-cl-hidden-form-wrapper">
                    <form id="gmw-cl-hidden-form" method="post">
                        <input type="hidden" id="gmw-cl-street" 		   name="gmw_cl_location[street]" value="" />
                        <input type="hidden" id="gmw-cl-city"   		   name="gmw_cl_location[city]" value="" />
                        <input type="hidden" id="gmw-cl-state" 			   name="gmw_cl_location[state]" value="" />
                        <input type="hidden" id="gmw-cl-state-long" 	   name="gmw_cl_location[state_long]" value="" />
                        <input type="hidden" id="gmw-cl-zipcode" 		   name="gmw_cl_location[zipcode]" value="" />
                        <input type="hidden" id="gmw-cl-country" 		   name="gmw_cl_location[country]" value="" />
                        <input type="hidden" id="gmw-cl-country-long" 	   name="gmw_cl_location[country_long]" value="" />
                        <input type="hidden" id="gmw-cl-org-address" 	   name="gmw_cl_location[address]" value="" />
                        <input type="hidden" id="gmw-cl-formatted-address" name="gmw_cl_location[formatted_address]" value="" />
                        <input type="hidden" id="gmw-cl-lat" 			   name="gmw_cl_location[lat]" value="" />
                        <input type="hidden" id="gmw-cl-lng" 			   name="gmw_cl_location[lng]" value="" />
                        <input type="hidden" id="gmw-cl-action" 		   name="gmw_cl_action" value="post" />
                    </form>
                </div><script type="text/javascript">
jQuery(document).ready(function($) {

    //declare new map options array for form ID 1
    gmwMapOptions['1'] = []; 
    gmwMapOptions['1']['styles'] = [
    {
        "featureType": "landscape",
        "stylers": [
            {
                "color": "#f2f2f2"
            }
        ]
    },
    {
        "featureType": "road",
        "stylers": [
            {
                "saturation": -100
            },
            {
                "lightness": 45
            }
        ]
    },
    {
        "featureType": "road.highway",
        "stylers": [
            {
                "visibility": "simplified"
            }
        ]
    },
    {
        "featureType": "road.arterial",
        "elementType": "labels.icon",
        "stylers": [
            {
                "visibility": "off"
            }
        ]
    },
    {
        "featureType": "administrative",
        "elementType": "labels.text.fill",
        "stylers": [
            {
                "color": "#444444"
            }
        ]
    },
    {
        "featureType": "transit",
        "stylers": [
            {
                "visibility": "off"
            }
        ]
    },
    {
        "featureType": "poi",
        "stylers": [
            {
                "visibility": "off"
            }
        ]
    }
]
});
</script>
<style type="text/css">
            h2.frq-main-title{
               font-size: 18px;
            }
            .hrf-entry{
               border:none !important;
               margin-bottom: 0px !important;
               padding-bottom: 0px !important;
            }
            .hrf-content{
               display:none;
               color: #444444;
               background: #ffffff;
               font-size: 14px;
               padding: 10px;
               padding-left: 50px;
               word-break: normal;
            }
            h3.hrf-title{
               font-size: 18px ;
               color: #444444;
               background: #ffffff;
               padding: 10px ;
               padding-left: 50px;
               margin: 0;
               -webkit-touch-callout: none;
               -webkit-user-select: none;
               -khtml-user-select: none;
               -moz-user-select: none;
               -ms-user-select: none;
               user-select: none;
               outline-style:none;
            }
            .hrf-title.close-faq{
               cursor: pointer;
            }
            .hrf-title.close-faq span{
               width: 30px;
               height: 30px;
               display: inline-block;
               position: relative;
               left: 0;
               top: 8px;
               margin-right: 12px;
               margin-left: -42px;
               background: #444444 url(https://entwickler.de/wp-content/plugins/html5-responsive-faq/images/open.png) no-repeat center center;
            }
            }.hrf-title.open-faq{
            
            }
            .hrf-title.open-faq span{
               width: 30px;
               height: 30px;
               display: inline-block;
               position: relative;
               left: 0;
               top: 8px;
               margin-right: 12px;
               margin-left: -42px;
               background: #444444 url(https://entwickler.de/wp-content/plugins/html5-responsive-faq/images/close.png) no-repeat center center;
            }
            .hrf-entry p{
            
            }
            .hrf-entry ul{
            
            }
            .hrf-entry ul li{
            
            }</style>


    <div id="wpfront-scroll-top-container"><img src="https://entwickler.de/wp-content/plugins/wpfront-scroll-top/images/icons/1.png" alt="" /></div>
    <script type="text/javascript">if(typeof wpfront_scroll_top == "function") wpfront_scroll_top({"scroll_offset":100,"button_width":0,"button_height":0,"button_opacity":0.8,"button_fade_duration":200,"scroll_duration":400,"location":1,"marginX":20,"marginY":20,"hide_iframe":false,"auto_hide":false,"auto_hide_after":2});</script>    <script></script>
    <script type="text/javascript">
	  jQuery(document).ready(function ($) {

//custom validation rule
$.validator.addMethod("customemail", 
    function(value, element) {
	return /^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$/.test(value);
    }, 
    "Sorry, I've enabled very strict email validation"
);


        $('#commentform').validate({
          rules: {
            author: {
              required: true,
              minlength: 2
            },
  //          email: {
  //            required: true,
  //            email: true
  //		},
	      email: {
                required:  {
                    depends:function(){
                        $(this).val($.trim($(this).val()));
                        return true;
                    }   
                },
                customemail: true
            },
            comment: {
              required: true,
              minlength: 1
            }
          },
          messages: {
            author: "Bitte geben Sie einen Namen an.",
            email: "Bitte geben Sie eine gültige Email-Adresse an.",
            comment: "Bitte geben Sie einen Kommentar an."
          },
          errorElement: "div",
          errorPlacement: function (error, element) {
            element.after(error);
          }

        });
      });
    </script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shCore.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushAS3.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushBash.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushColdFusion.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushClojure.js?ver=20090602'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCpp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCSharp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushCss.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDelphi.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushDiff.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushErlang.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushFSharp.js?ver=20091003'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushGroovy.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJava.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJavaFX.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushJScript.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushLatex.js?ver=20090613'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushMatlabKey.js?ver=20091209'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushObjC.js?ver=20091207'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPerl.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPhp.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPlain.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPowerShell.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushPython.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/third-party-brushes/shBrushR.js?ver=20100919'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushRuby.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushScala.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushSql.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushVb.js?ver=3.0.9b'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/scripts/shBrushXml.js?ver=3.0.9b'></script>
<script type='text/javascript'>
	(function(){
		var corecss = document.createElement('link');
		var themecss = document.createElement('link');
		var corecssurl = "https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shCore.css?ver=3.0.9b";
		if ( corecss.setAttribute ) {
				corecss.setAttribute( "rel", "stylesheet" );
				corecss.setAttribute( "type", "text/css" );
				corecss.setAttribute( "href", corecssurl );
		} else {
				corecss.rel = "stylesheet";
				corecss.href = corecssurl;
		}
		document.getElementsByTagName("head")[0].insertBefore( corecss, document.getElementById("syntaxhighlighteranchor") );
		var themecssurl = "https://entwickler.de/wp-content/plugins/syntaxhighlighter/syntaxhighlighter3/styles/shThemeDefault.css?ver=3.0.9b";
		if ( themecss.setAttribute ) {
				themecss.setAttribute( "rel", "stylesheet" );
				themecss.setAttribute( "type", "text/css" );
				themecss.setAttribute( "href", themecssurl );
		} else {
				themecss.rel = "stylesheet";
				themecss.href = themecssurl;
		}
		//document.getElementById("syntaxhighlighteranchor").appendChild(themecss);
		document.getElementsByTagName("head")[0].insertBefore( themecss, document.getElementById("syntaxhighlighteranchor") );
	})();
	SyntaxHighlighter.config.strings.expandSource = '+ Quelltext aufklappen';
	SyntaxHighlighter.config.strings.help = '?';
	SyntaxHighlighter.config.strings.alert = 'SyntaxHighlighter\n\n';
	SyntaxHighlighter.config.strings.noBrush = 'Keine Syntax-Datei vorhanden für: ';
	SyntaxHighlighter.config.strings.brushNotHtmlScript = 'Die Syntax-Datei ist nicht für die „htmlscript” Option konfiguriert: ';
	SyntaxHighlighter.defaults['pad-line-numbers'] = false;
	SyntaxHighlighter.defaults['toolbar'] = false;
	SyntaxHighlighter.all();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='https://entwickler.de/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='https://entwickler.de/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=230&#038;height=0&#038;ver=4.3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/assets/js/jquery.validate.min.js?ver=1.10.0'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"https:\/\/entwickler.de\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"sending":"Sending ...","cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.5'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/bootstrap-for-contact-form-7/assets/scripts.min.js?ver=1.3.1'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/sands-top-article-slider/assets/top-article-slider.js?ver=1.0.0'></script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/online\/windowsdeveloper\/force-feedback-programming-visual-studio-579766435.html?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=2.6.4'></script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/online\/windowsdeveloper\/force-feedback-programming-visual-studio-579766435.html?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};
/* ]]> */
</script>
<script type='text/javascript' src='//entwickler.de/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=2.6.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"de-DE","strings":{"Close":"Schlie\u00dfen","Fullscreen":"Vollbild","Turn off Fullscreen":"Vollbild beenden","Go Fullscreen":"Vollbild einschalten","Download File":"Datei herunterladen","Download Video":"Video herunterladen","Play":"Abspielen","Pause":"Pause","Captions\/Subtitles":"Untertitel","None":"None","Time Slider":"Zeit-Schieberegler","Skip back %1 seconds":"%1 Sekunde(n) zur\u00fcck springen","Video Player":"Video-Player","Audio Player":"Audio-Player","Volume Slider":"Lautst\u00e4rkeregler","Mute Toggle":"Stumm schalten","Unmute":"Laut schalten","Mute":"Stumm","Use Up\/Down Arrow keys to increase or decrease volume.":"Pfeiltasten Hoch\/Runter benutzen, um die Lautst\u00e4rke zu regeln.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Benutze die Pfeiltasten Links\/Rechts, um 1 Sekunde vorzuspringen, und die Pfeiltasten Hoch\/Runter, um 10 Sekunden vorzuspringen."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.22.0'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.6'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/plugins.js?ver=beta'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/html5shiv.min.js?ver=beta'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jmagzoption = {"ajaxurl":"https:\/\/entwickler.de\/wp-admin\/admin-ajax.php","copyclipboard":" URL kopieren f\u00fcr clipboard","shareto":"Artikel teilen hit","gacode":"","usezoom":"1","ismobile":"","commentscript":"disqus","disqus_shortname":"entwicklermagazin","fbapps":"125823254276164","isie":"","postid":"579766435","isblog":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/main.js?ver=beta'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public//js/zeroclipboard/ZeroClipboard.min.js?ver=beta'></script>
<script type='text/javascript' src='https://entwickler.de/wp-content/themes/entwicklerDE/public/js/ajax-post.js?ver=beta'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/comment-reply.min.js?ver=4.6'></script>
<script type='text/javascript' src='https://entwickler.de/wp-includes/js/wp-embed.min.js?ver=4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gmwSettings = {"general_settings":{"google_api":"AIzaSyA9QVPRKdNm3gpEd2_JmnD4n6U8tW2RFuk","js_geocode":"1","language_code":"DE","country_code":"DE","results_page":"191273","url_px":"gmw_","auto_locate":false},"post_types_settings":{"edit_post_zoom_level":"7","edit_post_latitude":"40.7115441","edit_post_longitude":"-74.01348689999998","post_types":["jobpost"]}};
var gmwMapOptions = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://entwickler.de/wp-content/plugins/geo-my-wp/assets/js/gmw.min.js?ver=2.6.4'></script>
	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PJK98V"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-PJK98V');</script>
	<!-- End Google Tag Manager -->
    <script type="text/javascript">
    	</script>
    
	<!-- End Google Tag Manager -->
    </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

Page Caching using disk: enhanced

 Served from: entwickler.de @ 2017-01-24 11:57:46 by W3 Total Cache -->