Zend Framework 2.3.9 und 2.4.2 fixen BC Breaks
Kommentare

Letzte Woche berichteten wir über die Releases der Zend-Framework-Versionen 2.3.8 und 2.4.1. Sie enthielten beide einen Bugfix für kritische Sicherheitslücken in den Komponenten ZendMail und ZendHttp.

Leider wurden die Security-Fixes nicht ausreichend getestet, was dazu führte, dass beide Versionen Brüche mit der Abwärtskompatibilität enthielten. Diese werden nun in Zend Framework 2.3.9 und 2.4.2 behoben.

ZF 2.3.9 und 2.4.6 mit Fixes für BC Breaks

Durch die Security-Fixes wurden einige Brüche mit der Abwärtskompatibilität eingeführt. So wurden UTF-8-E-Mail-Adressen unter Umständen nicht richtig erkannt oder Cookies mit Werten in Arrays nicht korrekt behandelt.

Eine vollständige Liste über alle Fixes der BC Breaks findet man in der offiziellen Release-Ankündigung, weitere Informationen im Changelog zum ZF 2.4.2 bzw. 2.3.9. Beide Versionen stehen ab sofort auf Website zum Download bereit.

Unsere Redaktion empfiehlt:

Relevante Beiträge

Meinungen zu diesem Beitrag

X
- Gib Deinen Standort ein -
- or -